Support » Plugin: NextCellent Gallery - NextGEN Legacy » NextCellent and Gutenberg

  • Will NextCellent provide compatibility with core version of Gutenberg? Majority of my websites depend on NextCellent. Lack of support for Gutenberg will force me to heavily modify these websites. Hope, it will be not necessary.

    Frank

Viewing 7 replies - 1 through 7 (of 7 total)
  • I raised this problem about 7 months ago, along with concerns about PHP 7.2 bugs and others have also report various bugs that need fixing.

    Sadly the author(s) have gone completely silent since the last update roughly a year ago. As such I am making plans to transition back to NextGen Gallery, which is something I don’t want to do but what choice is there if we have no support of any kind?

    Alternatively I believe NextCellent will work with the WP Classic Editor plugin still (I tested this on a beta sometime ago) but that’s not much good if you intend to use Gutenberg as the now standard approach.

    Plugin Author WPReady

    (@wpready)

    Hi there
    Issues about PHP 7.2 were solved in previous versions as 1.9.32

    I hope Frank is referring to https://plugincompat.danielbachhuber.com/
    something I wasn’t aware. I’ll take a look.

    A quick PHP7.2 test of NextCellent highlights a fair few possible problems for the future. Some can be ignored but most may need some code tweaks to fix.

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/class-ngg-album-manager.php
    ——————————————————————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————————————————————–
    101 | WARNING | The “result” parameter for function parse_str() is missing. Passing this parameter is no longer optional. The optional nature of the parameter is deprecated since PHP 7.2
    ——————————————————————————————————————————————————————————————–

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/functions.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    1245 | WARNING | INI directive ‘safe_mode_gid’ is deprecated since PHP 5.3 and removed since PHP 5.4
    —————————————————————————————————————

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/lib/imagemagick.inc.php
    ——————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————-
    103 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————————————————-

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/lib/meta.php
    ———————————————————————————————————–
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
    ———————————————————————————————————–
    99 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    185 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    260 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    402 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————–

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/lib/ngg-db.php
    ————————————————————————————————————
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ————————————————————————————————————
    910 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    970 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    1018 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ————————————————————————————————————

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/lib/swfobject.php
    ————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————-
    85 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ————————————————————————————————————-

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/widgets/class-ngg-gallery-widget.php
    ——————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————–
    252 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ——————————————————————————————————————————–

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/widgets/class-ngg-media-rss-widget.php
    ———————————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————-
    133 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————————————-

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/widgets/class-ngg-slideshow-widget.php
    ———————————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————-
    175 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————————————-

    FILE: /*******/wp-content/plugins/nextcellent-gallery-nextgen-legacy/nggallery.php
    ———————————————————————————————————–
    FOUND 0 ERRORS AND 12 WARNINGS AFFECTING 12 LINES
    ———————————————————————————————————–
    147 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    177 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    228 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    262 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    328 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    330 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    331 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    333 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    710 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    734 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    738 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    803 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ———————————————————————————————————–

    Plugin Author WPReady

    (@wpready)

    Thanks ispreview for bringing this issue(s).
    What tools do you use to check this?
    Thanks again.

    Via the PHP Compatibility Checker Plugin by WP Engine.

    Plugin Author WPReady

    (@wpready)

    Thanks I’ll be reviewing a new version fixing those problems and compatibility with Guten berg also.
    Thanks for your help.

    Excellent to hear!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘NextCellent and Gutenberg’ is closed to new replies.