WordPress.org

Support

Support » Plugins and Hacks » Next Link Animation Error?

Next Link Animation Error?

  • Cactushead
    Member

    @cactushead

    Works great overall but when I hover over the left side of the image the previous arrow link slides in from the top left (0,0) to the left middle of the image (0,50%) which looks correct.

    The right side next link however slides in from the top and middle (50%,0) of the image to the right middle (100%,50%) (diagonally across the image).

    Surely this is incorrect and it should slide in from the top right (100%,0) to the middle right (100%,50%)

    Hope my description is clear.
    The diagonal movement just does not look correct and I presume this is an error either as a whole or on my specific installation.

    http://wordpress.org/extend/plugins/wp-lightbox-2/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Pankaj Jha
    Member

    @masdiblogs

    I am not able to replicate. Please share your site URL.

    Cactushead
    Member

    @cactushead

    Hey Pankaj

    Thanks for your response on this matter.
    I have since looked at the styling in lightbox.min.css and found that the #nextLink required a little addition to fix this problem.

    The next link’s image needed to be set for the starting position of the animation to be correct – however I needed to set the image itself to “none” so that it is not displayed all the time.

    WAS
    #nextLink{right:0;float:right;}

    NOW
    #nextLink{right:0;float:right;background:none right 0% no-repeat;}

    My site is not yet live as I need to iron out the bugs – so now that is one less 😉

    I’m not sure if anyone else has experienced this but the “fix” is simple.

    I should point out that I did deactivate the plugin and delete it, followed by a re-install but I found this error still occurred, so looked into the CSS code and found the solution.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Next Link Animation Error?’ is closed to new replies.