Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Next Gen/Atahualpa/WP Super Cache Conflict

  • awesomeopp

    (@awesomeopp)


    I installed WP Super Cache 1.4.8, however the pages were not caching. Page source shows this error:

    <!– Page not cached by WP Super Cache. Blank Page. Check output buffer usage by plugins. –>
    <!– Page not cached by WP Super Cache. No closing HTML tag. Check your theme. –>

    Changed to Twenty Fifteen theme and caching worked fine. Changed back to Atahualpa 3.7.24, deactivated all plugins and went one-by-one. All of my plugins worked with WP Super Cache with Atahualpa except NextGen 2.1.62.

    Got any ideas on how to resolve this? I really like the theme and I have a lot of galleries. Trying to improve my pagespeed test so would really like to get this to work.

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author photocrati

    (@photocrati)

    @awesomeopp – Although I can appreciate your troubleshooting is pointing to NextGEN Gallery as the issue, I am not seeing how this would be the case given your theme would be generating the HTML for the page and NextGEN Gallery would only be a component of that page. Do you have any specific URL where this would be visible (such as in the page source) we could get a look at first-hand?

    Thanks!

    – Cais.

    awesomeopp

    (@awesomeopp)

    Hi Photocrati,

    Thanks for responding. Here is what I have done to try to identify the issue.

    I installed WP Super Cache and enabled it. Left the rest of the settings as default except debug which I turned on. When I opened my site the top of the page source had this message:

    <!– Page not cached by WP Super Cache. Blank Page. Check output buffer usage by plugins. –>
    <!– Page not cached by WP Super Cache. No closing HTML tag. Check your theme. –>

    However, there was a closing HTML in the page source on the very last line.

    I then disabled all of the plugins except WPSC and caching worked. I activated the plugins one at a time and checked the caching. When I got to NextGen I got the page not cached error. I then disabled all of the plugins except WPSC and NextGen and got the page not cached error. I then reactivated all of my plugins and switched from Atahualpa to Twenty Fifteen and caching worked fine with NextGen active. I have also deactivated, deleted, reinstalled and reactivated WPSC with the same results.

    That’s where I’m at. I am on the latest version of the theme as well as all of the plugins. I was hoping to avoid reinstalling the theme since there are so many settings, but that may be my last resort.

    site is spswoodturners.org

    Chirping Bird

    (@chirping-bird)

    Yes, same here. Have tried to unsubscribe to no avail.

    Plugin Author photocrati

    (@photocrati)

    @chirping-bird – Subscribing/un-subscribing issues might be something to have one of the forum mods look into further. I can appreciate how disruptive seeing multiple non-related notifications can be although unfortunately there is nothing (in most cases) a plugin author account can do.

    – Cais.

    Plugin Author photocrati

    (@photocrati)

    @awesomeopp – Have the WP Super Cache author(s) been able to shed any light on why this would happen and/or the Atahualpa theme author(s)? I don’t recall ever seeing anything like this before and not being familiar with either of their respective code-bases I wouldn’t know where to look to see how having NextGEN Gallery active with WP Super Cache _and_ Atahualpa as the current theme would trigger a HTML comment to be displayed to the screen.

    Thanks!

    – Cais.

    awesomeopp

    (@awesomeopp)

    The theme author over at bytesforall.com says he has tried the combination and doesn’t have a issue. Also says if you search for ‘Page not cached by WP Super Cache. No closing HTML tag’ there are several occurrences. Suggests using another plugin, but I get the same error with W3TC and cache enabler.

    WPSC hasn’t responded:
    https://wordpress.org/support/topic/no-closing-html-tag/#post-8653565

    Plugin Author photocrati

    (@photocrati)

    @awesomeopp – Our resource manage does change the order of some things although I do not believe it would be specifically behind this issue as many of our users have WP Super Cache installed and active on their site with little to no concerns and using our resource manager by default.

    You are welcome to try adding the following to Atahualpa’s functions.php file (as it is the odd man out in this scenario) to see if it helps:

    add_filter( 'run_ngg_resource_manager', '__return_false' );

    If it does not, please remove the code as it can have some unexpected issues depending on many contributing factors as it is a big part of our third-party compatibility code.

    Thanks!

    – Cais.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Next Gen/Atahualpa/WP Super Cache Conflict’ is closed to new replies.