WordPress.org

Support

Support » How-To and Troubleshooting » Next and Previous post links don’t work

Next and Previous post links don’t work

  • I’ve tried both of these options, but the links that used to be at the bottom of my pages that lead to the previous and next posts have disappeared:

    I tried this one with “previous_posts” and “previous_post”:


    <p class="post-navigation left"><?php previous_posts_link('� %link') ?>

    I also saw this somewhere and just tried it to see if it would make a difference. It doesn’t:


    <p class="post-navigation left"><?php next_posts_link('%link', '� Previous Entries', TRUE); ?>

    Please help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • If you are talking about the blog linked to your profile here… the links are there and working – just scroll down to the bottom of your webpage.

    Thanks for the quick reply. I’m talking about the pages for each post, though. It used to be that at the bottom of each page for each post, there would be a link with the post title in it that would take you to the earlier posts and the older posts (if there were any).

    Anybody else have any ideas?

    My idea is to read the documentation. It always helps…
    Template_Tags/previous_post_link
    and its pair

    The code you posted above is for multipost templates (index, archive, search…) as opposed to the template tag I linked to -which is for single post view!

    That link you gave contains code that is almost identical to the code I pasted. The only difference is that it’s (); and doesn’t have the parameters in it, right?

    Unless I’m retarded. Which, when it comes to code, is not that far-fetched.

    You just need new glasses…

    next_posts_link
    and
    next_post_link
    are not the same. The difference is an S for plural! I hate when people argue without reading carefully the resources offered. Read more and post less.

    Moshu,

    If you had read my initial post, you would see that I said (and I quote):

    I tried this one with “previous_posts” and “previous_post”:

    I tried it both with an “s” and without.

    If you had read more carefully my initial query you would have seen this. Your holier than thou attitude isn’t appreciated.

    Knowing this, do you have anything productive to offer as far as help? I’d like to solve this issue.

    did you solve your problem? im having this same problem

    Nope. It never got solved. If there’s anyone with knowledge out there OTHER than moshu who has an idea, please let me know.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Next and Previous post links don’t work’ is closed to new replies.
Skip to toolbar