Support » Plugin: ALO EasyMail Newsletter » newsletter widget + miss translation

  • Hello, in the widget, if I don’t fill the “privicy policy” radio button, the message “The Privacy Policy field is empty” which appear is not translated in french. I looked into the .PO (you gave in an other topic) but I didn’t find this field, and so there is no place where I can change it and I cannot translate this text.
    Is it possible to do something because the french people won’t understand ?

    And in the widget, I try to remove the text “Name” and “E-mail” before the field to fill and place those texts into the field instead (which erase itself when you fill your name and e-mail), so that the fields take all the width. I tryed to see in “alo-easymail-widget.php” and other pages but I didn’t succed to make those changes.
    Would you help me to change this ?

    Thank you for everything and excuse my bad english.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello, shalom

    I managed the translation problem, I finaly found the entry in the PO.

    Now in the widget, I still would like to remove the text “name” and “e-mail” before the fields. Instead, I would like them appear into the fields and make them disappear on clic. But also not allow to send the form if the field “name” is still name (if you don’t put your name)

    I hope you will answer…

    Todah raba !

    Plugin Author eventualo


    Hi, you cannot remove the name and email labels before the inputs via plugin settings.
    You can use some javascript to do it, e.g. add the following code into functions.php of your theme:

    function my_easymail_hide_form_labels () { ?>
            jQuery( document ).ready(function($) {
                var $emForm = $( '#alo_easymail_widget_form' );
                var $nameLabel = $emForm.find('.alo_easymail_form_table').find('label[for=opt_name]');
                $('#opt_name').attr( 'placeholder', $nameLabel.text() );
                var $emailLabel = $emForm.find('.alo_easymail_form_table').find('label[for=opt_email]');
                $('#opt_email').attr( 'placeholder', $emailLabel.text() );
    <?php }
    add_action( 'wp_footer', 'my_easymail_hide_form_labels' );

    thank you so much for your reply, it worked !
    I tried to change the length of the fields, I would like to have the same width for the fields (name and e-mail) and the submit button. I tried to change the CSS .alo_easymail_widget_form and .alo_easymail_widget_form .input-text { }, but it didn’t do nothing. I tried to add this in the theme CSS too.
    Where can I make thoose changes ?
    Thank you so much again !

    Plugin Author eventualo


    Hi, I think the CSS selectors you are using are right. Maybe there are other rules that are applied. If you cannot find them, you can use the “!important” attribute to your rules to be sure they are applied, e.g.:

    .alo_easymail_widget_form input.input-text { width: 100px !important }

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘newsletter widget + miss translation’ is closed to new replies.