Support » Plugin: SMTP Mailing Queue » newsletter sending problem

  • Resolved Faisal Ahmed

    (@fftfaisal)


    I am using your plugin and working fine, but I am also using weMail – Email Marketing plugin for send newsletter. this plugin has its own email sending option. their need to setup SMTP credentials again. when I trying to send a newsletter from this plugin is give up failed. I think these two plugins are conflict with the SMTP setting. How can I exclude wemail from your plugin? I have contact with them, they told me to try to disable the SMTP queue plugin. But I need it for better user experience while they checkout.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Birmania

    (@birmania)

    Hi @fftfaisal,

    Mhhh, if I understand your environment, you have :
    – SMTP Mailing Queue with SMTP options set (host, etc…)
    – WeMail installed with “Transactional Email” set in settings (https://getwemail.io/docs/wemail/settings/general/)

    What was your wishes against the behavior of these two plugins ? Maybe the following workflow ?
    – Transactional email are queue via SMTP Mailing Queue
    – Every X times, SMTP Mailing Queue send e-mails to WeMail API

    After going into their code, when “Transactional Email” option is set, they overwrite “phpmailer” so all emails are sent to their platform.
    In this situation, I think that you do not have to set SMTP credentials in SMTP Mailing Queue (you can leave the host field empty).

    I will try to install WeMail + SMTP Mailing Queue this weekend in order to reproduce your problem and propose a solution if any.

    Thanks again for your report !
    Yours faithfully,
    Birmania

    Plugin Author Birmania

    (@birmania)

    Hi @fftfaisal, i am coming back after lot of testing on fresh install with WeMail and SMTP-Mailing-Queue.

    Note that it was very difficult to debug as WeMail API is not documented and errors are hidden from user interface, only visible on REST API response body which is available when opening browser network tab…

    For the moment, my conclusions are the following :
    – If you use WeMail with sending as test mode, everything works fine with or without SMTP Mailing Queue
    – If you enable SMTP mode on WeMail, campaigns are broken (even without SMTP Mailing Queue). However, if you try the “Preview and test email” button in Campaign editor you can see that it works well.
    – If you enable SMTP + Transactional mode on WeMail, mails send via wp_mail (ex : test mail from SMTP Mailing Queue tool) are working as expected (queued on SMTP Mailing Queue then sent to WeMail SMTP configuration)

    Note : I have done my tests using free SMTP tool : https://mailtrap.io

    I think that you are currently experimenting the same trouble as these :
    https://wordpress.org/support/topic/wemail-campaign-failed/
    https://wordpress.org/support/topic/sending-status/
    https://wordpress.org/support/topic/campaign-doesnt-send-other-issues/

    My advice would be that they add logs to indicate what cause the failed campaign.

    On your side, can you please try to disable SMTP Mailing Queue and check if campaigns success (with SMTP sending mode) ?

    Yours faithfully,
    Birmania

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘newsletter sending problem’ is closed to new replies.