Support » Plugin: Add-on WooCommerce - MailPoet 3 » newsletter-abbo from checkout does not work

  • Resolved friedhelm

    (@friedhelm)


    I can see the option field to check to get a newsletter at checkout.
    If i check it, i get the message, that an e-mail is send, but it is not sent.
    As well the list(s) in mailpoet are not updated.

    what am i doing wrong?

    thanks a lot!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello, we just tested in our side and the plugin is working fine. In your case, we need the following information in order to debug the issue

    1. Are you using any custom field of mailpoet?
    2. Please mention your MailPoet version and the Add-on WooCommerce – MailPoet 3 plugin version
    3. Do you know how to read php error? If yes, do you see any error in the log file?
    4. Are you using any other MailPoet plugin other than MailPoet 3 free version (for example MailPoet premium or MailPoet 2)?
    5. What “Subscription Position” you are using (from WooCommerce > Settings > MailPoet tab)?

    Thanks

    this was fast!

    1. No
    2. MailPoet Version 3.41.0, Add-on WooCommerce MailPoet 3 Version 1.1.7
    3. Yes, No errors
    4. No
    5. Vor Abschicken der Bestellung, its the 8th position

    thanks a lot !

    Hello,

    Just checked in our side and the plugin works as expected (even in 8th position). In your side, other plugins or theme might conflicting. Could you please disable all the other plugins except WooCommerce, MailPoet Version 3 & Add-on WooCommerce MailPoet 3 and try again?

    Thanks

    I did a local installation of the shop and reduced all plugins to the following:

    a. WooCommerce
    b. MailPoet 3 (New)
    c. Add-on WooCommerce MailPoet 3

    therefore I found out there are two possibilities to double-opt mailpoet:

    1. in the mailpoet-3-plugin in mailpoet -> einstellungen -> WooCommerce.
    there i can set the option “Opt-in auf Bezahlseite”.

    2. setting the option in WooCommerce -> einstellungen-> mailpoet -> Abonnement aktivieren?
    (this is your plugin)

    ———

    in the end there are two option fields on the checkout in the payment-div.

    but only the 1. possibility is working in my configuration and the status of the customer changes from “ausgetragen” to “eingetragen”.

    ———

    then i tried to switch on

    d. WooCommerce germanized.

    after that even 1. possibility didn’t work. (the option-field on the checkout was not visible, only yours)

    ———–

    so i think i give it up now, customers shall register in the form 😐

    Hello,

    Sorry that it is not working on your side. Since there is no error message in debug/php log, it is hard to pinpoint the issue. In our side, both fields are visible.

    We hope you will find out the issue in you side. If you think we can help you, please let us know.

    Thanks

    It was a bug in the WooCommerce-germanized-plugin. The plugin overwrites the Standard-Terms-Checkbox of WooCommerce and so the checkboxes of Mailpoet and your Plugin.
    Dennis, the developer of germanized linked a new template for germanized, so now its working perfect: https://raw.githubusercontent.com/vendidero/woocommerce-germanized/master/templates/checkout/terms.php

    Thanks a lot!

    Hello, glad that the problem is sorted out in your side. Thanks for letting us know.

    Have a great day.

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.