WordPress.org

Forums

Yoast SEO
News SEO not working (5 posts)

  1. owolter
    Member
    Posted 1 year ago #

    For a few months now, the News SEO module part of WordPress SEO by Yoast has not been working for us.

    Google Webmaster Tools constantly reports this error:

    Issue:
    Missing XML tag

    Description:
    This required tag is missing. Please add it and resubmit.

    Example:
    Sitemap: windsorite.ca/news-sitemap.xml
    Parent tag: urlset
    Tag: url

    Line:
    5

    And looking at the XML file several times a day, it never updates, it never changes, and it never works even though we have dozens of news stories per day.

    http://windsorite.ca/news-sitemap.xml

    http://wordpress.org/plugins/wordpress-seo/

  2. Chris
    Member
    Posted 1 year ago #

    (1). Have you tried disabling your cache plugin and checking for errors?

    (2). Your sitemap xml is incorrect. Have you modified them or added code to individual files?

  3. owolter
    Member
    Posted 1 year ago #

    1) The entire plugin and its directories, including the XML files, have been already excluded from w3tc.

    2) No modification made whatsoever. Running the plugin as installed from its page here on WordPress.org.

  4. Chris
    Member
    Posted 1 year ago #

    Looks like you have fixed it now ??? The XML is working correctly.

  5. owolter
    Member
    Posted 1 year ago #

    Well, strangely, it's only showing a few select posts, when we've published quite a bit of other news since.

    Compare

    http://windsorite.ca/news-sitemap.xml

    to our RSS feed

    http://feeds.feedburner.com/windsoriteDOTca

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.