Support » Plugin: Email Subscribers & Newsletters - Simple and Effective Email Marketing WordPress Plugin » News post notification emails going to wrong people

  • Resolved lest44

    (@lest44)


    I submitted a news post this afternoon and the notification emails were sent out to our email subscribers as normal or so I thought. I had updated the plug-in to 5.0.1 yesterday, but think it has a serious problem. I see you have now updated to 5.0.2, which I have now installed, so I am hoping you have already fixed this problem.

    The problem was, I have a couple of emails set up on my subscribers list, one is my personal email and one is the clubs email address. These are quite useful to ensure I get both emails whenever I post a news post on the website to confirm it has worked ok. Today, both accounts received the notification emails to the correct email addresses and hence I have seen them, but I have noticed that the names within the email message were two other people from within our subscribers list. Also within the email, I have a part of it saying why they have received the message, i.e. because whatever@email.com has subscribed to the notification service and to give the option to unsubscribe if necessary. In both cases, the names stated ‘Dear Mr X’ and their email addresses were as per the subscribers list, but their email has come to a completely different email address. I have not yet heard of anyone else in my subscribers list letting me know they have received someone else’s email. I have over 70 subscribers and seriously hope your plug-in has not sent everyone other peoples notifications, therefore creating a leak of personal names and emails to the wrong peoples. I don’t understand why or how this has happened.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor kishanranawat

    (@kishanranawat)

    Hello there,

    Thanks for sharing the above information.

    The plugin sends emails in batches as set in the plugin setting. e.g. if you have 70 subscribers and in the plugin’s setting, the value of Maximum emails to send at once option is 30, then the plugin sends emails in 3 batches(30+30+10). Due to a bug in 5.0.1 version, for a given batch, it was replacing {{NAME}} and {{EMAIL}} placeholder with the correct values for first subscribers but for remaining subscribers in the batch, it was replacing with first subscriber’s name an email only.

    We have fixed the above mention issue in 5.0.2 version.

    We are extremely sorry for the inconvenience caused to you. also we will make sure it doesn’t happen again in the future.

    Thank you for your understanding!!!

    Thread Starter lest44

    (@lest44)

    Thank you for your quick reply and explanation. Hopefully your latest release will have fixed this issue. It does however beg the question how much testing of each new release are you actually doing prior to launch? This issue should have been found during thorough product testing of 5.0.1 to avoid it in the first place.

    Plugin Contributor kishanranawat

    (@kishanranawat)

    Hello there,

    Thank you for your response. The latest release should fix this issue.

    Yes, I do acknowledge the mistake in my testing but will make sure it does not happen again. We do thorough product testing but somehow this issue went unnoticed. As soon as we noticed the issue, we have released a new version with the fix.

    We are again extremely sorry for the inconvenience caused to you.

    Thank you for your understanding!!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.