Support » Plugin: SVG Support » Newest version breaks compatibility with php < 5.5

  • Resolved igarciaoliver

    (@igarciaoliver)


    Hi and thanks for the time and effort put into this plugin.

    The latest release breaks if php version is under 5.5. Reason being, empty can only check against variables, everything else will result in a parse error.

    I modified my version to fix it as follows:
    [code]
    $is_admin_notice_dismissed = get_option( 'bodhi_svgs_admin_notice_dismissed' );
    if ( ! empty( $is_admin_notice_dismissed ) ) { // remove the old admin notice db entry
    [/code]

Viewing 1 replies (of 1 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Hey @igarciaoliver,

    Thanks for your support 🙂

    I actually just pushed out another version that addresses this (2.3.14). Thanks for pointing out that it was PHP versions that was causing it… I had a quick dig, but just re-wrote that bit of code to fix the issue without finding out the full trace of the cause.

Viewing 1 replies (of 1 total)
  • The topic ‘Newest version breaks compatibility with php < 5.5’ is closed to new replies.