Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Newbie issues: litebox selection, unneeded thmbnail

  • Resolved tokyoprogressive5

    (@tokyoprogressive5)


    Hi and thanks for the long work you do on this plugin.

    I made test pages to see how the various galleries function.

    My purpose is to find a method that I don’t have to use hosting storage, so I made a two week test of smugmug.

    (I could use other plugins that send photos to storage but they seem complex and I don’t think pcloud works (i use pcloud).

    The instructions are complex so i may be misunderstanding.

    1) liteboxes. There are many listed but i am not sure how to select them. I go into settings litebox and choose one but it seems not to have effect. It also seems to be global so not related to one gallery.

    2) Titles (on my original photos (file name) do not show—only unless I add them in smugmug.

    3) In every gallery there seems to be a thumbnail that serves no purpose as clicking it takes me to Smugmug.

    Related to that are two views: one if i click on the photo and then it scrolls. Another if I close that view (big X) and then a much nicer view (litebox???) appears, though if i reach the end of the photos the first view goes back to the beginning. The nicer view does not.

    You can see
    https://nangoku-jiyu-jin.net/photonics-test/
    SQUARE GRID—>

    small photos

    SECOND JUSTIFIED GRID
    https://nangoku-jiyu-jin.net/photonix-test-2/

    Same STUPID top PHOTO
    Big picture good

    And when I get to the last photo and it goes to first, get small one (top photo)

    Again…why the nice one only after closing the show with X

    Third Masonry Even bigger but same stupid photo

    https://nangoku-jiyu-jin.net/photonix-test-3/

    Fourth Mosaic
    https://nangoku-jiyu-jin.net/photonix-test-4/

    Fifth Slide show
    https://nangoku-jiyu-jin.net/photonics-test-5/
    Doesn’t do anything
    no thumbnails below

    Sometimes click and nothing happens

    Other issues:
    A) Could issues be caused because I have meow gallery and Vimeotheque added ir just i need to follow instructions?

    B) I see trouble if I have two galleries on same page )(one pic every two clicks for example.

    C) in the future i may want to have a vimeotheque video gallery on the same page with a photo gallery.

    Can i add a vimeotheque video gallery?

    Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Sayontan Sinha

    (@sayontan)

    You need to disable your Meow Lightbox plugin since it is targeting Photonic galleries and causing a double-lightbox. The correct lightbox is from Photonic, which is showing up after you close the Meow Lightbox. Just like Photonic’s lightbox does not target other plugins’ photos, those plugins’ lightboxes should not target Photonic. Disabling Meow Lightbox will solve your lightbox-related issues.

    Once you have disabled Meow Lightbox, your selection from Photonic will be shown – all of the lightbox scripts listed there are bundled with the plugin, and you don’t need anything extra.

    For the header image, there are settings in Photonic → Settings → SmugMug → Photos (Main Page), to “Hide Album Thumbnail”, “Hide Album Title” and “Hide Number of Photos”. You can pick what you want to show.

    Plugin Author Sayontan Sinha

    (@sayontan)

    Following up regarding this. Can you please let me know of the status here? Did disabling Meow help you here? Note that you can use Photonic’s lightbox for non-Photonic images too, if you want (Photonic → Settings → Generic Options → Generic Settings → Photonic Lightbox for non-Photonic Images). This way, you will not need an additional lightbox.

    I also observed that you have enabled a lazy loading plugin – this sort of a plugin helps in cases where there is no layout optimization. Photonic has layout optimization built-in, so adding such a plugin causes some layouts to break, because such third party plugins are written for generic use cases. You should consider disabling your lazy loading plugin too.

    Thread Starter tokyoprogressive5

    (@tokyoprogressive5)

    Thank you for the two followups. Non stop work today so tomorrow will be my chance to work on this. I think the lazy load is also Meow Gallery or its lightbox.

    I will let you know the results of my tests tomorrow.

    Thread Starter tokyoprogressive5

    (@tokyoprogressive5)

    Oops. Not resolved. Hit checkbox by accudent.

    Thread Starter tokyoprogressive5

    (@tokyoprogressive5)

    Hi Sayontan Sinha and thank you.

    Much has been solved thanks to you instructions. At first it is overwhelming but after I read your explanation, it works!!!!

    a) Now I can hide the album thumbnail. Good.
    b) Titles

    I was thinking the plugin can take the title from the filename. It seems not. It seems only the title I add via smugmug. Oh well. I guess Smugmug does not let us use the FILENAME as the title?

    Also it seems it depends on the litebox if I can see the title in the litebox as well as the layout.

      Some comments

    1) I made a new test site because I wanted to use one that had no lightbox installed.
    It is here:

    https://tokyoprogressive2.org/photonics-test/

    It has all the photos at the top and all the videos at the bottom. But on my Iphone the videos do not load.

    (On the Mac it does not seem the button to load more affects anything but am wondering why the videos do not show on my phone?)

    2) The title (I made one) shows up at the top picture of food as well as in the litebox I chose!!!

    By the way in settings Nothing happens
    with this one: Normal title display using the HTML “title” attribute

    3) In the video (same gallery but only videos) I notice that in the litebox this word appears at the bottom. which I would like to get rid of.

    VIEW

    CONCLUSION
    I had been using Vimeography because I did not know Spummug has photos. Int seems rather than using Vimeography for the videos, I think I can now use your plugin for both!!!!! (But I am still worried about the video now showing on the phone).

    Thank you!!!

    paul

    Plugin Author Sayontan Sinha

    (@sayontan)

    It has all the photos at the top and all the videos at the bottom. But on my Iphone the videos do not load.

    I tried out your URL with Safari and Chrome on an iPhone, and at least the few videos that I tried loaded without any issues.

    (On the Mac it does not seem the button to load more affects anything but am wondering why the videos do not show on my phone?)

    The “More” button seems to work fine when I try out your site on all my browser combinations.

    2) The title (I made one) shows up at the top picture of food as well as in the litebox I chose!!!

    That is how it is supposed to work.

    By the way in settings Nothing happens
    with this one: Normal title display using the HTML “title” attribute

    Not sure I am following you. Nothing is supposed to happen with this, but if you hover over the thumbnail, you will see the title as if you didn’t have Photonic, for a regular HTML link.

    3) In the video (same gallery but only videos) I notice that in the litebox this word appears at the bottom. which I would like to get rid of.

    VIEW

    That only shows up if you don’t have a title and have lightbox linking enabled. “Lightbox linking” will take you to SmugMug if you click on that word. You need to have a word because otherwise there would be nothing to click for you to be able to go to SmugMug. If you disable lightbox linking, the “View” goes away, because then you no longer want to enable going to SmugMug from your site. You can disable this from Photonic → Settings → SmugMug → SmugMug Settings → Disable Lightbox Linking.

    Thread Starter tokyoprogressive5

    (@tokyoprogressive5)

    Thank you. I now understand what you explained. And now i am thinking to have photos and videos together (photos first) as it seems much easier and load time is good. Now Iphone seems ok. Maybe just a temporary occurrence.

    Because Smugmug allows videos i will now be able to use ONLY your plugin for both!!!!!!

    Thank you!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.