Support » Installing WordPress » Newbie blogger receives this error after typing in the URL

  • Resolved adprocepts


    I typed in my URL (below) and hit enter and got the below error and warning. Any help would be very much appreciated. Still kinda new to this blogging game but love it. Here’s how I entered my URL for the install: I hit enter and I get this fatal error and this warning.

    Warning: main(./includes/upgrade.php) [function.main]: failed to open stream: No such file or directory in /homepages/23/d227801315/htdocs/WordPress/wp-admin/install.php on line 10

    Fatal error: main() [function.require]: Failed opening required ‘./includes/upgrade.php’ (include_path=’.:/usr/local/lib/php’) in /homepages/23/d227801315/htdocs/WordPress/wp-admin/install.php on line 10

    Here is line 1 thru 18 on my install.php

    define(‘WP_INSTALLING’, true);
    if (!file_exists(‘../wp-config.php’)) {
    wp_die(“There doesn’t seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”, “WordPress › Error”);


    if (isset($_GET[‘step’]))
    $step = $_GET[‘step’];
    $step = 0;
    function display_header(){
    header( ‘Content-Type: text/html; charset=utf-8’ );

    I hope someone out there can help. This is the thrid time I have tried to install WP over the last 2 months. I have been very dsappointed, and just given up in the past. This time I intend to conquer this install. Sorta a personal thing now!

    Thanks in advance for any help and I hope this is enough information.


Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator kmessinger


    It can’t find the file upgrade.php which should be in the includes folder.

    Did you deleted all files from previous installs and not just write over them? Did you use ASCII when FTPing the files?

    Hey there Kmessinger,

    Thanks for responding to my post.

    This was a completely new install. I downloaded WP, unzipped to my desktop and then FTP’d the files.

    And yes, I do have the upgrade.php file in the includes folder. I am assuming that my HTML Kit (my FTP editor) transferred the files in the appropriate format. Should it be ASCII, not binary? I’m not sure how to check for this. The HTML kit is sometimes difficult to use. Should I do another install with something like filezilla? Or Dreamweaver?

    Also, when you mentioned rewriting I did do something that may have caused a problem. I forgot to use notepad when I put in my DB name, password etc, in the wp-config file. I copied and pasted that info from a word document. I then (after my first attempt of the install) went back in and overwrite that info using notepad, but still got the same error.

    I’ll check the HTML kit for different settings for the ASCII and see what I can come up with. Thanks very much for the help.

    I will not be denied!!


    Thanks, to everyone who helped.


    I got this message too.

    Clean install under a folder called blog.

    upgrade.php is there. and it’s not corrupted.

    the issue was I was looking not looking at the admin includes. these files had failed to load under ftp.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Newbie blogger receives this error after typing in the URL’ is closed to new replies.