Support » Plugin: Use Google Libraries » New WP 4.0 Media Library Doesn't Load

Viewing 13 replies - 16 through 28 (of 28 total)
  • I was having a similar problem, but not the same. My media library loaded fine, but the Widgets and Menus pages had an error. I couldn’t do anything on those pages because of this js error:
    TypeError: b.menuList.sortable is not a function
    http://…/wordpress/wp-admin/js/nav-menu.min.js?ver=4.0
    Line 1

    IT NOW WORKS after deleting and re-installing the plugin. I love this plugin and have it on just about every website I develop on. Until today I thought it was just the luck of the draw if it works with WP 4.0. On some sites I had to deactivate it. Today i went back to those sites, re-installed it and it seems to work now. Not sure if it’s because of the order WordPress reads in the plugins or maybe I cleared some cache (in db and browser), but works ok for me now. (btw, some of these sites were brand new so upgrading to 4.0 doesn’t seem like a cause)

    Thanks for the great plugin.

    sorry, to be clear, I didn’t specifically clear any cache in the db or browser. just thinking that was a side effect of deleting the plugin.

    Plugin Author Jason Penney

    (@jczorkmid)

    It’s possible deactivating and reactivating caused UGL to reinit, and that fixed it. That should happen if the UGL or WordPress version number changes, but maybe that’s not working.

    Update: It is not working again on the site that UGL wasn’t working and then started working after reinstalling. I installed “W3 Total Cache” and then “UpdraftPlus Backup and Restoration” plugins and the the Menus page no longer works. Sorry, not sure which plugin is the cause. I get the following js error in chrome (in Firefox no error appears, but similarly, nothing is clickable)

    Uncaught TypeError: undefined is not a function nav-menu.min.js?ver=4.0:1wpNavMenu.initSortables nav-menu.min.js?ver=4.0:1wpNavMenu.init nav-menu.min.js?ver=4.0:1(anonymous function) nav-menu.min.js?ver=4.0:1j jquery.js?ver=1.11.1:2k.fireWith jquery.js?ver=1.11.1:2m.extend.ready jquery.js?ver=1.11.1:2J

    What’s worse is UGL no longer works even after uninstalling the plugins mentioned and reinstalling UGL. I tried with a Incognito window also to make sure nothing was cached. No luck. So sad, I will have to deactivate this plugin for this site.

    Is it possible to not run UGL on the admin side? Or maybe at least have a setting or a hook so developers can disable it for the admin side only?

    Plugin Author Jason Penney

    (@jczorkmid)

    If you’re seeing version strings on jquery.js then UGL isn’t loading from Google anyhow. It looks like concatenation was somehow re-enabled (which UGL disables, since there’s an issues with script concatenating not loading in the correct order when they rely on scripts that aren’t in the same concatenation call in WordPress core). Not sure what’s causing that.

    I just upgraded to WP 4.01 and suddenly this problem started. Tried it in FF and IE, and on different machines. Read this thread – I don’t use Google Libraries but do have Google Analytics. Updated it and all other plugins. Restarted. Same problem persists. This is desperate. I have clients on WP all wanting to update for Christmas. Help?

    I’m having the same issue and I don’t have Google Libraries. I deactivated any new plugins and that didn’t fix the issue.

    In further desperation, I deactivated all plugins. I had overlooked also having Google Calendar. With no plugins active, that seemed to fix the problem. I’m now working through the plugins to find out which is/are the culprit.

    Since this happens to some of us but not all, I’m wondering if there is an environmental aspect – our operating system, platform, memory capacity, hosting company’s set-up, or suchlike.

    Plugin Author Jason Penney

    (@jczorkmid)

    Pippin and Cristi,

    Neither of you are using Use Google Libaries and are having this error? You probably want to start a thread somewhere else then because nothing I do in UGL is going to fix your issue if that’s the case.

    Well, I suppose we could do that. But this was the only thread I found that mentioned the problem and surely it would be useful to know that Google Libraries may not be the only culprit. Hope to have time to experiment more myself, tomorrow, and perhaps will post again in a spirit of general informativeness. Or start a new thread, as you suggest.

    Just wanted to chime in and mention that this bug has just hit 2x of my WordPress blogs. It caused the ‘Add Media’ button to stop functioning. The issues only seemed to start with the WordPress 4.1.1 update. In the Console it showed the error with ‘postbox.min.js’ as mentioned by other users above. Disabling UGL fixed the issue.

    I had a similar issue.

    I did try Jason Penney’s UGL plugin, but I cannot for the life of me find that bug with that plugin. So congrats on fixing it Jason, at least for version 1.6.2.

    However, my “Add Media” button problem was with another plugin. For those with an “infinite loading” BUG looking for a solution, please take a look at this post :

    https://wordpress.org/support/topic/the-add-media-button-loads-forever-with-my-plugin-add_action-shutdown?replies=1#post-6727263

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘New WP 4.0 Media Library Doesn't Load’ is closed to new replies.