Support » Plugin: Use Google Libraries » New WP 4.0 Media Library Doesn't Load

Viewing 15 replies - 1 through 15 (of 28 total)
  • Been using this plugin for a long time. Updated to WordPress 4.0 today and the Media Library won’t load in WordPress 4.0 with the plugin enabled.

    Came here to say the same thing. Deactivated Use Google Libraries and it was AOK again.

    Same issue. After deactivating Use Google Libraries I could load my media again.

    Plugin Author Jason Penney

    (@jczorkmid)

    I’m not able to reproduce the issue, but maybe something in my dev version has already fixed it. I’ll revert to the last release and try it.

    Can someone explain the steps to reproduce, and what exactly you’re seeing.

    Update: I can’t reproduce it with 1.5.2. Either I’m doing something different than all of you, or I’m missing something. Steps to reproduce would be most helpful.

    All I know is that when I upgraded to WordPress 4.0, I could not access my media. I had to deactivate the plugin and I then had access again. I am using Firefox as my browser and I did not try it with Chrome or IE.

    I will try to delete the plugin and install it again and see what happens.

    This might be specific to my website but I deleted and reinstalled with no luck on Firefox. I then used Chrome and it worked fine. I switched back to Firefox and it then worked. It seems to be specific to Firefox but maybe other users could try my workaround above. I did not test on IE.

    Thanks for a really nice plugin Jason.

    Hmm… reactivated the plugin to check today and everything seems nominal. Could be an older version got cached somewhere down the line.

    I’ll let you know if it pops up again.

    Plugin Author Jason Penney

    (@jczorkmid)

    I’ve released the (long overdue) new version, which didn’t seem to have any issues for me with 4.0. Let me know if it helps, or not.

    Updated, no dice. It looks like the file that the plugin is replacing with the Google jQuery file contains several libraries more than jQuery.

    It’s not working in any browser for me. I can still upload images but they don’t display in the library view and therefore cannot be selected and inserted into posts.

    Plugin Author Jason Penney

    (@jczorkmid)

    Could anyone still having the issue please do the following:

    • enable WP_DEBUG, and let me know if UGL outputs any messages
    • let me know what other plugins you have active

    Thanks

    Hey, i am not a technical guy and dont know much about WP_Debug… Had to deactivate it… Big fan though.. Will keep on checking this thread, till the issue is completely resolved.

    Same issue of not able to access media after the latest plugin update.

    Plugin Author Jason Penney

    (@jczorkmid)

    Hey, if anyone wants to see if 1.6.2 solves this issue for them, and let me know, I’d appreciate it.

    Jason, I have the same issue – see another post I commented on earlier.

    Here’s a list of the plugins I’m using…

    Akismet 3.0.2
    Contact Form 7 4.0.1
    Custom Meta Widget 1.4.6
    InfiniteWP – Client 1.3.6
    iThemes Security 4.4.21
    Login Security Solution 0.48.0
    NextGEN Gallery by Photocrati 2.0.66.29
    Really Simple CAPTCHA 1.8
    Use Google Libraries 1.6.210
    WordPress Database Backup 2.3-alpha
    WordPress SEO 1.6.3
    WP List PlugIns 2.2
    WP Migrate DB 0.6.1
    WP Smush.it 1.6.5.4

    WP_DEBUG doesn’t output anything interesting….
    Notice: add_contextual_help is deprecated since version 3.3! Use get_current_screen()->add_help_tab() instead. in /var/www/gggggg/wp-includes/functions.php on line 3201

    Any ideas?

    Tom

    I have more info on this problem.

    I’m using WordPress 4.0 with “Use Google Libraries” 1.6.2 and the Add Media button does nothing when I click it.

    I’m using Chrome 38.0.2125.111 but the same problem happens in IE 11.

    As a test, I disabled all plugins except “Use Google Libraries”, and changed the theme to Twenty Fourteen.

    When I edit a page in the admin area of my blog, I get the following error in the Chrome JavaScript console as the page first loads:

    Uncaught TypeError: undefined is not a function postbox.min.js?ver=4.0:1

    I swapped the contents of wp-admin/js/postbox.min.js with the contents of the non-minified version of the script (postbox.js), and then I get a better error message, which points to line 78:

    Uncaught TypeError: undefined is not a function postbox.min.js?ver=4.0:78

    Line 78 is the following line in postbox.js in the “init” function:

    $('.meta-box-sortables').sortable({

    When I search for “meta-box-sortables” in the source of the admin page, I find the following three references:

    <div id="side-sortables" class="meta-box-sortables">

    <div id="normal-sortables" class="meta-box-sortables">

    <div id="advanced-sortables" class="meta-box-sortables">

    As TomCobbley said, WP_DEBUG doesn’t output anything related to your plugin.

    When I disable “Use Google Libraries”, the JavaScript console error goes away, the Add Media button works again, the three div’s are still there, and I see in the source of the admin page that “postbox.min.js” is no longer being loaded.

    I’m a web developer myself — let me know if you’d like me to try something.

    Thanks,
    Russell

    Just a followup… I assume the problem is that the jQuery UI “sortable” function isn’t being loaded.

    Russell

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘New WP 4.0 Media Library Doesn't Load’ is closed to new replies.