Support » Plugins » New Version of the iTunes Podcast Plugin

  • If you’re running a podcast through WordPress, I could use your help testing the latest version of the wp-ipodcatter plugin for making a iTunes compatible feed (including keywords, duration, and block).

    The latest version also includes an admin panel under the WordPress Options tab for setting itunes:subtitle, default categories, and cover images.

    As an added bonus, you can also turn your blog’s comment feed into a podcast.

    http://garrickvanburen.com/downloads/wpipodcatter09a.zip

Viewing 15 replies - 1 through 15 (of 69 total)
  • I installed the plugin and filled the info in the ipodcatter admin panel, but Still no image in the image square in iTunes… can you help ?
    My rss is : http://boudaz.com/blog/wp-rss2.php

    Thanks !

    Run your feed through the Nobody Likes Onions FeedCheck. If the images show up, then it’s up to Apple.

    It does show up in onions… damed Apple !?%/

    Hey – I installed the v7 and it worked great, and v9 seems to work fine, too. A few things I’m unsure of, though:

    First, my feed is at:
    http://www.highestpraise.com/podcast/?feed=rss2

    #1: Although I’ve entered “Religion and Spirituality:Chrisanity” as the category:subcategory … which shows up fine in the <itunes> tags … the main rss category is: <category>Talk Radio</category>

    I don’t have “Talk Radio” entered anywhere??

    #2: In the <item> tags, it doesn’t complete “author” … it leaves this blank:
    <itunes:author> </itunes:author>

    The author is completed earlier in the RSS feed, but not in the <item> area.

    Look forward to your reply,
    Fred McKinnon

    http://www.highestpraise.com/podcast/

    OK – fixed the author thing … it was parsing from the WordPress author’s tag … which was only “siteadmin” … I logged into WordPress > Users > SiteAdmin and updated the profile by filling out the name, etc., and this corrected it.

    As for “TalkRadio” – that is hard coded in the wp-rss2.php file … I talked to Garrick and he told me about it … I just changed it to the category of my choice, and all is well – no errors, no missing tags. Great plugin!

    The next version of the plugin won’t have ‘talk radio’ hard coded.

    This plug-in is looking great! I found the one on your site, but was disappointed that it didn’t include support for cover images. Please keep us posted about future versions. And thanks for making it!

    Jeremy,

    The 0.9a version supports both Apple’s 300*300 iTunes cover image and an RSS standard channel image @ 144*144px.

    http://garrickvanburen.com/archive/call-for-testers-wp-ipodcatter-09a
    http://garrickvanburen.com/downloads/wpipodcatter09a.zip

    Yeah, sorry, I know this. That’s why I was excited to find the thread. Keep up the great work!

    I installed the plugin, activated, did everything as instructed, but I’m getting the following error message when I check it in the Nobody Loves Onions feedchecker:

    Xml Data error ‘80040002’
    Unable to parse Xml: The following tags were not closed: rss, channel, item.

    /feedcheck/incRSS.asp, line 135

    Any clues?

    My RSS is at:
    http://www.addictedtorace.com/?feed=rss2

    take a look at what feedvalidator says:

    http://feedvalidator.org/check.cgi?url=http://www.addictedtorace.com/?feed=rss2

    Looks like the plugin can’t find the getid3 directory. It looks like I
    neglected to include it in the v1.0 zip file.

    My apologizes. Redownload the plugin fromhttp://garrickvanburen.com/download/wpipodcatter.zip , and upload the getid3 directory to your plugin directory.

    Let me know if that solves the problem.

    The code in the getid3 directory automatically detects the duration of the podcast for the itunes:duration tag. It only does this if the mp3 files are in the same directory as WordPress.

    Thanks for setting up your podcast like this and bringing this oversight to my attention.

    Couple of issues I have found with version 1.0 using feedvalidator.com:

    – “Undefined channel element: itunes:link” <itunes:link rel="image" type="video/jpeg" href="http://www.wachs.org/weddingcast/audio/podcast_cover.jpg">Countdown to Chaos</itunes:link> This does not seem to be a well formed tag. Why is the link going to the artwork and not the actual MP3 file?

    – All my durations show as “Invalid Duration”. My podcast MP3 files live in a directory called “audio” inside the root wordpress directory. Must I put these MP3’s in the root of wordpress?

    – “Keywords must be words separated by spaces” <itunes:keywords>Pre-wedding Podcast</itunes:keywords> It seems my keywords are separated by spaces. If I want to hard code these keywords, do I need to do that in rss2.php?

    The actual page is: http://www.wachs.org/weddingcast/wp-rss2.php

    cwachs,

    The itunes:link tag error with FeedValidator is a known issue. The href should be a link to your podcast’s ‘cover image’. Set this as a URL in the WP-iPodCatter options panel, under Podcast Cover Image URLs.

    On the ‘invalid duration’ issue, make sure the ‘local path to audio files’ at the bottom of the WP-iPodCatter options panel is the full server path to your /audio/ directory. In your case, I suspect it will be your WordPress recommended File Upload destination directory with /audio instead of /wp-content.

    If you want to use the same keywords for every podcast, then yes, it may make more sense to hardcode them in the RSS file. Alternativesly, you could set ‘pre-wedding podcast’ as the default category and select ‘use WordPress categories’ for itunes:keywords.

    Was this helpful?

    I am still unable to get the duration tag working. In the local path, I have “/Volumes/Web/wachs-org/weddingcast/audio/” which is the path on my machine to the MP3 files. The root of WordPress is in “/Volumes/Web/wachs-org/weddingcast/” I’ve tried using just “/audio/” in the path for MP3 files but that does not work either. Am I using a http://…. path for this?

    Chad

Viewing 15 replies - 1 through 15 (of 69 total)
  • The topic ‘New Version of the iTunes Podcast Plugin’ is closed to new replies.