Support » Plugin: NextGEN Public Uploader » New version of NextGEN Gallery breaks NextGEN Public Uploader

  • Public uploader no longer works. Getting this message “NextGEN Public Uploader requires NextGEN Gallery in order to work. Please deactivate NextGEN Public Uploader or activate NextGEN Gallery” within admin.

    NextGen Gallery IS installed and activated.

Viewing 15 replies - 1 through 15 (of 23 total)
  • subscribing

    Plugin Author Michael Beckwith

    (@tw2113)

    can you try deactivating both and then activating NextGEN Gallery core first, and then Public Uploader afterwards? I’m not managing to recreate the issue at the moment, and those steps above are the ones I took.

    Hi Michael,
    I have the exact same problem.
    The Public Uploader has stopped working. I tried your suggestion of deactivating both, and then activating NextGen Gallery first and then the Uploader. But it still doesn’t work.
    Here is the error message in Admin: NextGEN Public Uploader requires NextGEN Gallery in order to work. Please deactivate NextGEN Public Uploader or activate NextGEN Gallery.

    Plugin Author Michael Beckwith

    (@tw2113)

    Looks like our following check is failing in the main plugin file:

    if ( ! class_exists( 'nggLoader' ) ) {
     ...
    }
    

    Does everything still work if you change that line to check for C_NextGEN_Bootstrap ?

    For what it’s worth, we haven’t ensured guaranteed support for the 2.x line of NGG. Definitely have upload kinks that need worked out still. We realize it’s a potential inconvenience.

    Hi Michael,
    Unfortunately, not sure I know exactly what to do. At least the galleries are working fine. I have 26 of them on my website https://fishingmag.co.nz

    Same here…

    Same prob.

    I’m having the same problem. I tried this fix and it did NOT work.

    • This reply was modified 1 year, 6 months ago by  gsfergusson.

    Hi there @tw2113 – Just wanted to say thank you for the hard work on this plugin. I know at times like these the community can seem ungrateful when you only hear from us when there’s an error on your free plugin that we’ve been using for years. Thanks again!!!

    Plugin Author Michael Beckwith

    (@tw2113)

    @gsfergusson what aspect didn’t work? For example, did it successfully load the rest of our plugin, but something else broke afterwards? Still didn’t successfully load anything and gave the message at the top?

    Plugin Author Michael Beckwith

    (@tw2113)

    For those not sure what to change, please try this version: https://cloudup.com/cufb7pb7bGG

    Hi Michael- After substituting in ‘C_NextGEN_Bootstrap’ in place of ‘nggLoader’ the plugin successfully loaded your plugin but it failed to function and the “NextGEN Public Uploader requires NextGEN Gallery in order to work.” message reappeared.

    I also tried deactivating both Nextgen and Nextgen Public Uploader and then reactivating them in the order suggested, and again your plugin loaded OK, but failed to work and as above, the error message reappeared.

    George-

    Plugin Author Michael Beckwith

    (@tw2113)

    Looks like these changes from the latest version have put NextGEN Gallery loading later than our plugin: https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=1586018%40nextgen-gallery%2Ftrunk%2Fnggallery.php&old=1577363%40nextgen-gallery%2Ftrunk%2Fnggallery.php&sfp_email=&sfph_mail=

    Essentially they’re trying to force Pro/Plus to load first, but it appears that it’s also forcing it to load after ours as well.

    Makes perfect sense Michael, and explains the symptoms.

    Best of luck pondering a solution to this issue! As has been mentioned above: “Just wanted to say thank you for the hard work on this plugin. I know at times like these the community can seem ungrateful when you only hear from us when there’s an error on your free plugin that we’ve been using for years. Thanks again!!!”

    George-

    Thank you Michael for the explanation, I really appreciate your hard work and patience with us.

    For now, I’ve downgraded Nextgen Gallery (and now the uploader works flawlessly) and wait for any possible solution.

    Regards,
    GermanSC

    • This reply was modified 1 year, 6 months ago by  GermanSC.
Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘New version of NextGEN Gallery breaks NextGEN Public Uploader’ is closed to new replies.