Support » Plugin: OMGF | Host Google Fonts Locally » New version fonts dont show up

  • Resolved sigagan

    (@sigagan)


    Hi,

    Just installed the latest version 4.0.1 and the fonts are now NOT being loaded from local OMGF cache. Was working fine before.

    Used default settings. Previously I had my Autoptimize setting set to Remove google fonts. So, I changed that as it wont enqueue the font for OMGF to recognize. Then tried “Combine and link in head” both link deferred and not defereed and still no luck.

    • This topic was modified 4 months, 4 weeks ago by sigagan.
    • This topic was modified 4 months, 4 weeks ago by sigagan.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    It is a major update. Did you flush Autoptimize (and other caching plugins) caches?

    Hi,

    I’ve just tried the update on one of my sites and I’m seeing the same thing. I also had Autoptimize set to remove Google fonts so I changed that and flushed everything but nope…no Google fonts.

    I also see there’s been a major change to the settings page as well. I can only guess that the default options mimic what it used to do, but it’s clearly not working at the moment so I’ve reverted back to the previous version and won’t be updating any more sites at the moment.

    Thread Starter sigagan

    (@sigagan)

    Yep, I can see stylesheets generated in the css folder. I cant see fonts in uploads/omgf folder.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Well, this sucks…

    Guys, could you provide me with a bit more info so I can try to figure out what’s going on?

    Are you getting any errors in your PHP logs?
    What theme are you using?
    What caching/css minify plugins are you using? (besides Autoptimize)

    Thread Starter sigagan

    (@sigagan)

    No errors. I am using Primer theme. Caching – Autotimize and wp-optimize

    p.s. I am in the middle of backup, and will be rolling back soon. But happy to help investigate the issue.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I think I found it. In some situations OMGF could trigger too late for the requests to be captured.

    Just released an update (v4.0.2). Is one of you guys willing to try?

    Thread Starter sigagan

    (@sigagan)

    I’ll give it a shot when the update comes through.

    • This reply was modified 4 months, 4 weeks ago by sigagan.
    Thread Starter sigagan

    (@sigagan)

    Fonts are now coming through. There are 3 issues

    1. CDN setting is not working for below file. It works for the fonts.

    http://www.example.com/wp-json/omgf/v1/download/css?family=Ubuntu%3A300%2C400%2C700&subset=latin&handle=primer-fonts&ver=1.8.9

    2. This is a new warning on GTMetrix >> The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources:
    http://www.example.com/wp-json/omgf/v1/download/css?family=Ubuntu%3A300%2C400%2C700&subset=latin&handle=primer-fonts&ver=1.8.9

    3.Maybe allow fonts to be preloaded, seems like this has been removed.

    • This reply was modified 4 months, 4 weeks ago by sigagan.
    • This reply was modified 4 months, 4 weeks ago by sigagan.
    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    1. It’s correct that that URL isn’t called through the CDN, because that’s OMGF’s Download API. It’s only supposed to be triggered at the first pageload, though.
    2. Same goes here, after the Download API downloaded all the fonts and generated the stylesheet, the download API shouldn’t be called anymore. Try flushing the cache of your full page caching plugin. What happens when you run it again?
    3. Yes, preload has been removed from this release. It will be re-introduced soon, though. In a different form, with more features.

    You removed the preload option… now some fonts are not working anymore. X(

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    @leandrvs,

    Could you clarify? Not preloading a font should not break the loading of a font.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.