The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Jetpack by WordPress.com
[resolved] New version breaks wp-ecommerce (5 posts)

  1. mxv
    Posted 3 years ago #

    The latest version of Jetpack breaks wp-ecommerce which I use for the store portion of my site.

    Product pages, the main store page, etc are all blank.

    I tried deactivating jetpack and then the store works normally. I tried to delete/reinstall jetpack. When I did this, i was unable to connect to wordpress.com to activate jetpack if the wp-ecommerce plugin was active. I deactivated the wp-ecommerce and then was able to connect jetpack. However with jetpack plugin active, the store is once again broken. Regardless of whether jetpack is connected to wordpress.com doesn't matter, either way it it stopped my store from working.

    http://www.punkvinyl.com/store is my site that you can see the blank page due to jetpack being enabled.

    Please help!


  2. designsimply
    Plugin Contributor

    Posted 3 years ago #

    I checked http://www.punkvinyl.com/store/ and I see the store working right now. I also checked http://www.punkvinyl.com/ with the Jetpack debug tool at http://jetpack.me/support/debug/ and it appears you have disconnected Jetpack from WordPress.com.

    Can you either re-connect it temporarily and try to get some useful debugging information by looking in your browser console when you load the page or by looking at your server error logs? If you can do either of those things, or if you can provide any more detailed information at all, it would help.

  3. Illya King
    Posted 3 years ago #

    E-Commerce just upgraded their program. Publicize still does not work with E-Commerce loaded. I've switch to NextScripts: Social Networks Auto-Poster for my auto posting needs.

  4. Illya King
    Posted 3 years ago #

    Whoops... my error. I deactivated the WP E-Commerce plugin, connected the Publicize connections, and reactivated the WPEC plugin and everything works now.

  5. designsimply
    Plugin Contributor

    Posted 3 years ago #

    @illyaking, thanks for the update! It does appear that the WP e-Commerce developers fixed the issue on their side. I found the following under "" in their plugin changelog:

    Fix: Compatibility issues with Jetpack.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic