[Resolved] New version breaks PHP 5.2 compatibility
Since 0.9.9.9, the plugin no longer works with PHP 5.2 because of the new Piwik API that uses namespaces.
This needs to be put forward very clearly in the documentation for the plugin. Right now the readme just says “PHP 5 or higher is strictly required.”.
Also, there needs to be some sort of detection for PHP 5.2, because right now users just get a nice white blank screen when updating from 0.9.9.8 to 0.9.9.9.
(Yes I know PHP 5.2 is ancient, but some users still run it.)
- The topic ‘[Resolved] New version breaks PHP 5.2 compatibility’ is closed to new replies.