Support » Plugin: WP-Piwik » New version breaks PHP 5.2 compatibility

  • Since, the plugin no longer works with PHP 5.2 because of the new Piwik API that uses namespaces.

    This needs to be put forward very clearly in the documentation for the plugin. Right now the readme just says “PHP 5 or higher is strictly required.”.

    Also, there needs to be some sort of detection for PHP 5.2, because right now users just get a nice white blank screen when updating from to

    (Yes I know PHP 5.2 is ancient, but some users still run it.)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author braekling


    Please see regarding this issue.

    The readme will be updated with the release later this day.

    Important note: PHP 5.2 is not only ancient… it reached its “end of life” status 3 years ago. Everybody who is still using PHP 5.2 should update as soon as possible, because the PHP team does not support PHP 5.2 anymore – this means no bug and especially no security fixes anymore.

    It may well be the case that PHP v5.2 isn’t supported anymore. However, some web hosts still use it by default and WordPress itself runs just fine on PHP v5.2.

    The minimum version of PHP supported by WP-Piwik should be clearly stated in the change log and documentation. No excuse for incorrect information or omitted that.

    Plugin Author braekling


    The minimum version supported by WP-Piwik is clearly stated in the documentation:

    Also PHP 5.3 or higher is strictly required.

    If a web host still uses PHP 5.2 as default, which isn’t supported by the PHP developers for over 3 years, you should urgently tell them. Using deprecated software versions may cause critical security issues.


    While I agree PHP 5.2 is old, it is still receiving security patches for Red Hat and CentOS distributions until March 31, 2017, so I disagree about the security issues aspect, as all fixes are being backported to the 5.2 branch on RHEL / CentOS.

    Another fun fact: almost half of all WordPress sites (42.9%) run PHP 5.2.

    Plugin Author braekling


    Of course there may be some specialized solutions to keep 5.2 alive, but these are no “official PHP developer team backports”. Have a look at Debians description of backports:

    Backports cannot be tested as extensively as Debian stable, and backports are provided on an as-is basis, with risk of incompatibilities with other components in Debian stable. Use with care!

    I’m sorry, but I don’t have time to take care on software buried several years ago by its own developers – I also won’t test WP-Piwik with WordPress 3.5 or less just because of more than 50% of WordPress sites still running old copies.

    And at least: Piwik itself asks for PHP 5.3 since Piwik 2.0, see

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘New version breaks PHP 5.2 compatibility’ is closed to new replies.