Support » Plugin: WP-SCSS » New version 1.2.5 not compiling properly

Viewing 15 replies - 1 through 15 (of 20 total)
  • The problem seems to be that the plugin doesn’t create its necessary “cache” directory. If you create that directory it seems to work fine. Good luck!

    Hi!
    I updated to version 1.2.5 today and I got the same issue as @majkelruffin but I solved it by creating a cache directory, but it doesnt seem as its parsing the new SASS I create. I dont get any error messages and in the inspector it shows the old code but if I click on the link to the .scss file in the inspector it shows my new code. Any idea how I can solve it?
    Thanks!

    • This reply was modified 9 months, 2 weeks ago by kawebb.

    @makane-wp where should I create a cache? Is it the theme scss directory or in the plugin?

    Hi @thezenmonkey — In the plugin directory: plugins/wp-scss — Good luck!

    I also had to create the cache folder, but it only compiles if I save the main style.scss file. Saving any of the imported _file.scss doesn’t cause it to compile.

    I’m also having this issue. Tried the cache folder trick – no luck sadly. Rolled back to 1.2.4 with the manually updated scssphp files to get around the previous compiling issue.

    When I save my main.scss file the compilation work, but Im hoping for a new update of the plugin soon.

    Julie

    (@juliejubilee)

    +1 for the issue of imported files not compiling on save

    Same issue here. Downgraded to 1.2.4 and it’s working normally again.

    Manan

    (@vyasmanan007)

    Same issue here. The updated version does not compile. It only works after I delete .css file and reload the page. Sadly downgrade to 1.2.4 version and it works.

    It should be fixed asap.

    kentnerd

    (@kentnerd)

    I can confirm what others have said (as I tested this thoroughly like a mad-man):

    for version 1.2.5, my new styles did not apply until I 1) created a cache folder from inside the wp-scss plugin folder, and 2) opened up my style.scss file and saved the file (even though there was nothing to save). I literally just opened the file, and hit ctrl + s

    Afterwards, the styles apply.

    Same issue like (@neilparnold), downgraded works fine. It only compiles the main style.scss file but to compile other scss, you need to save style.scss file. Hope the plugin author will go through it and will solve the issue.

    Thanks for the great plugin.

    Same issue, had to downgrade. Please fix this soon!

    I can above confirm the above issue:

    After ensuring the cache folder is created, it only compiles if I save the main style.scss file. Saving any of the imported _file.scss does not trigger it to compile.

    Julie

    (@juliejubilee)

    For those looking for an interim solution who are comfortable messing with the plugin’s code, I tried out the solution in this Github thread and it worked for me: https://github.com/ConnectThink/WP-SCSS/issues/131

    It doesn’t fix the cache folder creation, but it will let imported file changes trigger compilation again.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘New version 1.2.5 not compiling properly’ is closed to new replies.