WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] New users can’t register for accounts

[Resolved] New users can’t register for accounts

Viewing 7 replies - 1 through 7 (of 7 total)
  • Try to create a “dummy” script to test whether your mail() is really disabled. (I use 1and1 as well, and as of this morning I can still receive emails from my site’s contact form).

    pnaw10
    Participant

    @pnaw10

    Great idea… though I’m not sure exactly how to do this. While not exactly a novice at WordPress, I’m nowhere near being an expert, either. If you are able to tell me how I can test this out, I’d be very appreciative.

    At least it’s good to hear from someone else using 1and1. They seem to have their little hiccups now and then, and it seems the only place to get answers is from fellow 1and1 users.

    Thanks!

    <?php
    mail("YOUR@EMAIL.HERE", "test mail() function", "test mail message") or die("something went wrong. :(");
    ?>

    Replace YOUR@EMAIL.HERE with your own email, save it as .php, upload to your site and run it in a browser. If it works, you should receive the email in a few minutes.

    pnaw10
    Participant

    @pnaw10

    Thanks for that script!! Now that I’m back home from work… I tried it, and sure enough, “something went wrong.” Very strange, as I can’t quite figure out why this happened.

    I guess my next step is to figure out why mail() isn’t working, and how to get it back to normal. I have one of the lower-end 1and1 accounts, so I don’t have access to all the bells and whistles (like SSH/telnet access).

    I’ll poke around and see what I can figure out… if I get it fixed, I’ll reply with my findings, for anyone else who might have the same problem. If anyone out there sees this thread and I haven’t responded yet, feel free to post your own suggestions/ideas for a solution. Thanks again!

    pnaw10
    Participant

    @pnaw10

    Well, I contacted my hosting provider, 1and1, and here’s what they had to say about it.

    Thank you for contacting us.

    This issue has no relevance on the upgrade of our php features, possibly the cause for this one is that, the database of your registration is already full. And just double the configuration of your wordpress for registration.

    What?? I can’t find anything in WP documentation about any limits to the number of users — or where I would go to change that number. The new users are showing up in the user list — they just aren’t getting the e-mail to confirm their account has been opened.

    pnaw10
    Participant

    @pnaw10

    After several more hours of looking around, I’ve found a handful of solutions. None of them work. I tried the WP-Mail-SMTP plugin to bypass mail() but that was no good.

    I also found this blog post, which suggests that there may be errors in the mySQL database causing this error message. But I have no reason to believe this is the problem — and even if I did, the stupid article doesn’t say what to look for within the database. It tells you how to fix problems, but it doesn’t tell you what a problem would actually look like.

    And, thanks to haochi, I’ve found that mail() still fails to work even when it’s run from a non-Wordpress PHP file. So I’ve sent an e-mail to 1and1 support insisting the problem is on their end, and they need to fix it. It apparently seems to be a problem on their end with their PHP settings.

    If this is resolved soon, I’ll post an update. But I still have a sneaking suspicion it may have been caused by my upgrading to WP 2.5, so I’m not marking it “resolved” yet. If anyone out there has any other ideas in the meantime… speak up!!

    pnaw10
    Participant

    @pnaw10

    OK, my hosting provider finally admitted it was a PHP problem on THEIR end, and they finally fixed it. Situation resolved. Sorry for blaming WP 2.5. Please don’t hate me.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] New users can’t register for accounts’ is closed to new replies.