Support » Fixing WordPress » new user registration – no password sent

  • I am setting up a new blog ( When I try registering a new user it says that the password will be emailed, but it never arrives… any ideas?


Viewing 11 replies - 1 through 11 (of 11 total)
  • Mark (podz)


    Support Maven

    When you created the blog, did YOU get an email ?

    If you did, then the problem is WP’s
    If you did not, then the problem is with your host and a non-standard way of using mail.

    Hi all

    I am suffering from a simialr fate – i get the new user registration mail to my mailbox, but the password email is not arriving – it arrived once and then the users that followed got no password – anybody have a solution ????

    Many thanks

    I have the same problem, but the thing is, I’m hosting WordPress on my own server.

    I don’t get an email when a new user registers. I also don’t know how to set up email addresses that WordPress can use.

    Hope someone can help, thanks!

    I’m brand new. I’m not sure where to post this– but I didn’t get a password to get into my blog to edit etc.! I tried everything I usually use. How do I get a username and password? Thank you Helen


    The last screen of the WordPress installation does report the admin login and password. If you don’t have that then you’ll need to read Resetting_Your_Password. It’s easy to use phpMyAdmin to change your password. Good Luck!

    Welcome to the WordPress Support Forums!

    Please help keep the Forums successful by reading:
    Using the Support Forums

    Also, remember the WordPress Codex and the FAQ pages.

    And, thank you, for letting us know if this information proves useful (or not)!

    When I installed WordPress I got the email with the username and password for the admin, but if a user registers the screen says a password has been sent but no email arrives. I know this question has been asked before, but I dont see an answer to it.

    Please help.

    @eidi: wordpress sends the email to user “admin” (his e-mail)
    But to send emails you have to change the php.ini file:
    In the [mail function] section of the file you have to insert your SMTP mail server address.

    Hope this helps

    I too am having the same problem. I use dreamhost. My blog is at I can’t find a php.ini file on my server. I know some of what I’m doing, but apparently not enough. If I need to edit MySQL, what do I need to edit?

    Because of problems with SPAMMERS exploiting mail sending scripts, my ISP ( now requires all users to log-in to their SMTP server before allowing any email to be sent. This means no registration or notification emails get through (and would account for the problems explained in a number of other recent threads). I can’t find a way to do this authentication within WordPress – nor any pointers in the forums or plugins guides. Any suggestions would be very welcome – and would solve email problems for a number of users, I guess.


    Problem solved by the use of Scott Reilly’s wpPHPMailer Plugin which can easily be configured to authenticate and use a specific SMTP server. Latest version requires no modifications to core scripts.

    This is available from:

    Description: Enable WordPress to send e-mail via SMTP instead of via PHP’s mail() function.

    Hope this helps.

    I’ve tried that and it’s not working for me.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘new user registration – no password sent’ is closed to new replies.