WordPress.org

Support

Support » How-To and Troubleshooting » New user registration emails not sending out!

New user registration emails not sending out!

  • I upgraded to the latest version of wordpress yesterday, as well as changing server providers.

    The problem comes when new users register on to the website – it promises them that it will send a confirmation email with the username and password but this email does not get sent out.

    I, as administrator, don’t also get notification emails saying when a new user signs up or when new comments are added for moderation.

    I’ve read all the other forum topics on this issue but still can’t find a suitable remedy for this problem. Is it just a case of changing a few PHP lines? Or do I have to do more?

    Any help would be greatly appreciated!

    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’ve checked with my host and the php mail() function is activated, so I don’t know why emails aren’t being sent!

    Any ideas?

    Ps: I can’t use SMTP as an alternative…

    I’m experiencing similar problems here. The hosting setting works fine with wordpress 2.5 but after upgrading to version 2.51, I found that users do not receive confirmation email and I also do not receive admin notifications.

    Please, any ideas how to fix this ?

    Thanks in advance.

    Did you ever get this problem resolved? I have a 2.7 version and no emails are being sent fromt he blog – not to new users neither to me as an administrator. Thanks

    I have had the same problem! Please help!

    Anyone solved this?

    I definitely had email problems with 2.5, but haven’t with 2.7.

    Except when on a server that wasn’t configured to send emails.

    Definitely setup a simple file to test php’s mail() function to be sure that it is definitely working…

    Until you do that, there is not point troubleshooting further.

    Make a file that has something like this in it:

    <?php
    $email = 'you@youremail.com';
    $fromemail = 'me@myemail.com';
    $subject = $_POST['subject'];
    $msg = 'This is a test';
    $headers = "From: ".$fromemail;
    if( !mail($email, $subject, $msg, $headers) ){
    	echo "Problem sending email.";
    }else{
    	echo "Email successfully sent";
    }
    ?>

    Change the email addresses to something real. And then visit that page, make sure it give you a success message, and then make sure you get the email.

    I spent about 5 hours debugging this problem today. There are plenty of posts about it on this forum, but not many solutions.

    For me, with both WP 2.7 and 2.7.1, I was getting the admin notification for new users, but the new user wasn’t getting the email with their password. Same with password retrieval.

    The WP SMTP plugin didn’t fix it either. Turns out that my host (HostGator) apparently doesn’t allow emails to be sent with URLs in them. To get things working again, I commented out the following line in the wp_new_user_notification function of wp-includes/pluggable.php.

    //$message .= site_url(“wp-login.php”, ‘login’) . “\r\n”;

    Password retrieval is still a problem because the URL is necessary to generate the new password.

    I am having this problem as well. I tried JCow’s solution, inserted the page in my wordpress directory, went to the page, got the success message and have not received an e-mail. Where do I look next for the problem? Do I need to set up an e-mail server on the machine which is hosting my wordpress install? I have built a server strictly to set up a blog installation. It is running Debian and Apache, MySQL and PHP5.

    I found a solution to this problem and you can find it on my forum at http://www.mhare.com.au/forum/

    Well I got further along thanks to Mark’s advice. I followed his instructions and I received the following error message:

    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    +OK ednaisd.org POP3 MDaemon 10.0.4 ready
    SMTP -> FROM SERVER:
    -ERR unknown POP3 command!
    SMTP -> ERROR: EHLO not accepted from server: -ERR unknown POP3 command!

    SMTP -> FROM SERVER:
    -ERR unknown POP3 command!
    SMTP -> ERROR: HELO not accepted from server: -ERR unknown POP3 command!

    SMTP -> FROM SERVER:
    -ERR unknown POP3 command!
    SMTP -> ERROR: MAIL not accepted from server: -ERR unknown POP3 command!

    SMTP -> FROM SERVER:
    -ERR that command is valid only in the TRANSACTION state!
    SMTP -> ERROR: RSET failed: -ERR that command is valid only in the TRANSACTION state!

    I am thinking this is telling me that the reason e-mails are not being sent is that oure-mail server on our school network is set up to reject these e-mails for some reason. Can anyone tell me what that reason might be? The reason I ask is because our network admin will need to know what needs changing when we bring a blog on line. Thanks, Dennis

    SCRATCH THAT LAST MESSAGE OF MINE!!!!! MARK HARE, YOU RAWK DUDE! We are hot straight and normal! Issue resolved!

    Here’s another solution with a 100% success rate just in case nothing else works: http://www.roblayton.net/archive/wordpress-not-sending-emails-anymore-solved/

    well my wp also wont send email to new user, i installed WP Mail SMTP plugin (this was only one working) but apparently there is some error in wp script. as i can see what happens when mail is sending because i host wp on my computer and i use mercury mail for delivering messages. for other sites and my own script message sending works fine through smtp.gmail but wordpress sends messages like this <wordpress@mydomain.com and mercury wont send messages like this. where and how to fix that wrong format code. mercury need format like wordpress@mydomain.com or Admin <wordpress@mydomain.com> with both <> not just only one < .there i get message error.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘New user registration emails not sending out!’ is closed to new replies.
Skip to toolbar