Support » Plugin: WP Mail SMTP by WPForms » New User Registration Email Not Sent in version 2.0

  • Resolved mzaheerdad

    (@zaheerdad)


    It’s to inform that new version 2.0 have contradiction with new user registration email. It’s not beinf send. When i revert to version 1.9.0 all works fine. The issue is with only new user registration email

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the same issue. The plugin WP Mail Log shows a “SMTP Error: Could not authenticate”. But the test email works fine, there is no issue. The sender name and email is the same, also the “force” option doesn´t solved the issue.

    Have you an idea, what the reason could be?

    Thanks in advance!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @zaheerdad and @yoneo12,

    could you please check the server PHP error logs to see if there are any errors, that might cause this issue.

    Also, please tell us which mailer you are using in our plugin and which PHP version your server is running on.

    Thanks and have a nice day!

    Thank you for your reply!

    In my PHP error log is nothing related to the emails.

    I have also disabled other email-related plugins, that hasn´t solved the issue. You find here the error that I can see in mail log plugin: https://1drv.ms/u/s!Asaa-3t8-bVzgd8KhkKdaSsI3uNUxw?e=wymyu6

    I am using my own SMTP server from the hosting. I have also tried another SMTP account from another hoster. But that hasn’t solved the issue, that the registration email isn´t sent.

    I am using PHP 7.4.4.

    Do you have another idea?

    Thanks in advance

    Yoneo12

    On the screenshot, you can see that the test mail is send out successfully.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @yoneo12,

    I’ve just tried to reproduce the issue on my test site, using “other SMTP” mailer with gmx.com SMTP and “force from email” enabled, but both the admin email and the user email for WP registration was successfully sent and delivered.

    The “Force from email” checkbox should be enabled on your site (just want to make sure).

    Could you please try to deactivate all plugins except the WP Mail SMTP and try a WP registration again? I would just like to eliminate any plugin conflict issues.

    Thanks and take care!

    Hi @capuderg,

    thank you so much for your detailed response.

    I have deactivated all plugins except the necessary one: Redux Framework, WooCommerce, WP Mail SMTP, TI Wishlist. Without these plugins, my website isn´t accessible.

    But the same error still occurs (Mail log: SMTP Error: Could not authenticate). I have marked all force overwrite checkboxes. The test mail via your plugin still works…

    Have you an idea of how to fix this?

    Best regards

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    thanks for testing the plugin conflict issue.

    I see you are using WooCommerce… are you by any chance using the constants for the SMTP password field in wp-config.php?

    If so, please try do remove those constant settings and add the SMTP password in the plugin settings.

    Let me know if that will resolve your issue.

    Take care!

    Thank you for the fast reply.

    Yes, that has worked. After I had added the SMTP password in the plugin settings (and removed from wp-config.php), the email is successfully sent.

    I don´t know, why this happens. If it is a bug, can you maybe fix it in the next version? I think it is a security issue when the password is stored in plain text.

    But it is really nice that this is working now.

    Best regards

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    this issue has been reported before and we are never able to reproduce it.

    The issue has something to do with WooCommerce + SMTP password in constants. We tried to reproduce it a bunch of times, but we just can’t get the issue on our WP sites 🙁

    If we could reproduce it we would also fix it…

    Are you maybe using some special WooCommerce settings? Anything special on your server, PHP configuration?

    It would be awesome if we could get access to one of these failing WP sites, but of course, that can’t be a production site.

    Would you be prepared to create a new WP site with WooCommerce and WP Mail SMTP installed and configured on your web hosting and see if you can reproduce this issue again (SMTP password set with constant)? If you could reproduce it on this new test site, we could exchange emails and share access to the site privately and so we could debug and potentially fix the problem for good 🙂

    Have a nice day!

    Hi,

    I am using the WP Mike Hosting Service. I don´t know any special setting. There is no free trial possible, so I cannot test it with a new installation.

    I am using regularly the also the following plugins, which are maybe connected to the issue: SIP Advanced Mail, Follow Up Email, WP HTML, and Woocommerce Germanized.

    If you want to take a look at my page, you can contact me via my homepage. I can also send you some reports about my page or give you staging access.

    Best regards and also a nice day

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    I’ll contact you (followed on twitter). Maybe debugging on the staging site would be a good solution.

    Thanks and have a nice day!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    for anyone else experiencing this issue. Please check your wp-config.php file and move the plugin’s constants code you added to the file, above the /* That's all, stop editing! Happy publishing. */ line. Like so: https://a.supportally.com/nw7JLN.

    Have a nice day!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘New User Registration Email Not Sent in version 2.0’ is closed to new replies.