Support » Installing WordPress » New User – install problem can’t find wp-load.php file

  • Hello everyone – This is probably a simple problem, but can’t figure it out…

    1) I installed the wordpress file directly under the xxxx directory; wp-admin, wp-content, wp-includes are all within wordpress file.
    2) wp-load.php exists wordpress folder, I copied it into the wp-admin folder as well;
    3) wp-config.php exists in wordpress folder

    the errors are as follows – I’m sure that some file(s) are not in the right place

    Warning: require_once() [function.require-once]: Unable to access ../wp-load.php in /htdocs/userdirs/xxxx/wordpress/wp-admin/admin.php on line 20

    Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /htdocs/userdirs/xxxx/wordpress/wp-admin/admin.php on line 20

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/local/php-5.2.13/libdata/php-5.2.13/php’) in /htdocs/userdirs/xxxx/wordpress/wp-admin/admin.php on line 20

    I’d appreciate any advice as to where to put the files so I can get it to work. Thanks!


Viewing 6 replies - 1 through 6 (of 6 total)
  • Make sure wp-load.php has proper permissions. Also, check the size of this file. If it is zero then probably it is corrupted.

    Thanks, Kailash…

    wp-load.php is non-zero, I opened it up in notepad to see that it is there. I assume that it is ok…

    the permissions are the same as the other files (adfrw), so that doesn’t seem to be it…

    I’m having the same problem. Just installed on a Windows/IIS system, and when I tried to access wordpress/index.php, I got the error

    Fatal error: require_once() [function.require]: Failed opening required ‘./wp-blog-header.php’

    I went into wordpress/index.php, and changed the reference from ‘./wp-blog-header.php’ to ‘wp-blog-header.php’, and that solved that problem.

    But I get the same kind of error when I try to access wordpress/wp-admin/index.php

    Fatal error: require_once() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.;c:\PHP5′) in D:\Inetpub\xxxx\wordpress\wp-admin\admin.php on line 20

    I think the relative file reference looks OK. If I’m in wordpress/wp-admin/admin.php, I think that the reference of ../wp-load.php should point to wordpress/wp-load.php, which is a valid non-zero-byte file. Any ideas? The code in wp-admin/admin.php is

    if ( defined(‘ABSPATH’) )
    require_once(ABSPATH . ‘wp-load.php’);

    When unzipping the wordpress files, make sure you select the ‘extract absolute path’ option. The file structure will then be what wordpress wants and you can stop having these require_once errors. Hope that helps!


    I have the same problem and wordpress was installed using the ms web installer

    Due to this problem we have installed on 4 different servers. 3 came up just fine however our public web server won’t work.

    The problem on IIS is exactly as jayrwilder describes except the logon/admin error is slightly different

    [19-Apr-2010 18:55:01] PHP Warning:  require_once(wp-load.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in D:\Domains\\www\wordpress\wp-admin\admin.php on line 20
    [19-Apr-2010 18:55:01] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'wp-load.php' (include_path='.;C:\php5\pear') in D:\Domains\\www\wordpress\wp-admin\admin.php on line 20

    I must also add that installing php has also been more difficult on this server. In the end we are using fast-cgi and have had to configure IIS manaully for php/cgi. The server does not have a default website and handles multiple domains.

    Is this a permissions problem? If so what needs to change?

    i have same exact problem.

    on this post +

    there seems to be no solution!! forum is therefore useless.
    how can such problems occur, they waste so much time & money, when WordPress is hailed as an amazing web build platform. since can not help, as they offer no help apart from forum, no eMail, no phone support, i contacted for to see if they stand behind their product, but they said to contact! vicious cycle.

    if the 2 do not support their quality, who will!?

    the problem or errors discussed seem to be due to corruption. but as several users have tried to redownload WP & re-upload all files, it does not work.

    can someone at WP move their behind and help. if such little problems kill your project as the site does not show up, what is the point of a platform based on such ridiculous sensitivity.

    sure, once all runs smoothly, wp is perfect, but it’s such a hassle and waste of time to get there. even with logic. it’s too sensitive. one might as well join or

    anyway, i put in too much prep time into wp, can someone please help us all.

    thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘New User – install problem can’t find wp-load.php file’ is closed to new replies.