Support » Networking WordPress » new user doesnt show up

  • kawgeorge

    (@kawgeorge)



    I am the super admin.
    When I go to the Users-> Add New I have 2 options, add existing and add new. When I add New, I enter the User Name, email, and set the role. Then click “Add New User” Nothing happens (or appears to) and if I go to the “All Users” the user I just added is not there. I thought maybe they would get an email wanting them to click as a confirmation that they would then set password etc. I have tried a couple of different users and roles and seems the only only that ever works is admin. The new user doesn’t get an email.

    Note I am doing this on one of the sub-domains. Do I need to first set the user up at the top level before adding to the sub? I dont want the user on all of the sites, only a certain one.

Viewing 4 replies - 1 through 4 (of 4 total)
  • This resembles what I wanted to ask here namely how you can enable registrations for other users than the admin. First of all gives domain/wp-signup.php an incomplete page of my theme instead a form as the WP login. When I add the meta to one of my widgets sometimes there is no link to register. I wonder if this feature still exists and if it isn’t disabled for spam reasons.

    On another installation, there is a link to register but the e-mail with the activation link never arrives. Neither do I find a checkbox or so in the admin to enable new registrations.

    jkhongusc

    (@jkhongusc)

    OP –
    On a subsite there are two options when adding new users. Let me explain in a bit of detail:
    1) Add Existing User – This means the user already has an account in WP; and most likely a role on another subsite. You can view all the “network” users in the network admin menu. You need to check the “Add the user without sending an email that requires their confirmation.” box, otherwise the user will get an email with a confirmation link.

    2) Add New User – This means the user does not have an account in WP. Adding a new user will create a network user; and give the user a role on that subsite. You need to check the “Add the user without sending an email that requires their confirmation.” box, otherwise the user will get an email with a confirmation link.

    Note that if you are having email issues on your server, the user accounts will not get created. In addition, there is a 3 day period before you can attempt to add the user to WP.

    I would try figuring out why users are not getting emails. Is your WP server sending them, or maybe a spam filter is blocking them.

    I just got this too or something similar. I disabled everything but a few absolutely essential security and multisite helpers. I could then see an error that the username could only use lower case letters.

    One of the harder issues in my blogging is searching contact with those subscribers. If other than commenters of course but they don’t need to sign up for me. Maybe one day I start emailing them, but I came upon something else I could do: just adding those users myself as they don’t show up in my administration.

    @bitpath, did you solve that issue? Because I think that’s quite simple. I think that you just have to try again just one or some more times.

    @superadmin, Maybe that function is dropped as a consequence that most users give a fake email address???

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘new user doesnt show up’ is closed to new replies.