Support » Fixing WordPress » NEW: Upgrade to 1.5.2

  • Read the dev blog.

    Backing up your database and files is recommended before ANY upgrade

    ==== The official method.====
    Upgrade just like any other upgrade:
    – delete
    /wp-admin
    /wp-includes (but NOT your languages folder!!)
    all wp-* files at root EXCEPT wp-config.php
    (Leave /wp-content and /wp-images alone.)

    – upload the replacements for what you have deleted (so don’t upload /wp-content or /wp-images)

    Use the link in the Dev blog to read the Codex page on upgrading.

    There is no need to run upgrade.php after doing this.

    ====The UNofficial method====
    Right now I don’t have the changelog, but a list of the changed files is below. If you do it this way, you are on your own as far as support is concerned.
    wp-admin/categories.php
    wp-admin/edit-page-form.php
    wp-admin/post.php
    wp-admin/upload.php
    wp-admin/users.php
    wp-commentsrss2.php
    wp-includes/comment-functions.php
    wp-includes/functions-post.php
    wp-includes/pluggable-functions.php
    wp-includes/template-functions-category.php
    wp-includes/version.php
    wp-settings.php
    xmlrpc.php

    These can be downloaded from here:
    http://firasd.ath.cx/wordpress-changed-final.zip

    =====
    Before posting questions, please read all other posts in this thread and also the Codex page. It may well save you time.

Viewing 15 replies - 16 through 30 (of 94 total)
  • Please !!! DO NOT FORGET THE INTERNATIONALIZATION RULES GUYS !!!

    DO NOT DELETE \wp-includes\languages FOLDER !!!

    THANKS.

    Villas

    Joni

    (@jonimueller)

    I went ahead and renamed my two original folders, wp-admin-old and wp-includes-old, and then uploaded the new, folders and all. That way, I could fish around in the old folders for a file if need be. Then once the site looked good to go (after kicking all the tires), I just zappd the two *-old folders.

    HTH someone else.

    jonimueller: excellent idea. This should be the recommended way 🙂

    >>Yeah, depending on the FTP program they mostly just get uploaded over the top of the old files and very occasionally this can cause an error since the old one isn’t completely deleted.<<

    That’s kind of vague… I’ve been doing FTP overwrites for probably 10 years now and never encountered the problem. I use ws_ftp pro so maybe that doesn’t have the problem, or maybe I’ve been lucky. The ftp server is (I think) part of Apache, running under Unix. Can you narrow the problem down to specifi ftp clients, servers, or OSs? Actually it sounds like either an OS bug or a transfer mode problem (e.g. overwriting an ascii file with a binary transfer.
    FWIW this is my second upgrade, and I did the first one (…2 to ….3?) this way with no problems, but sure wish it could be automated. Also FWIW my host provides WP with one button installation, and on the last upgrade they told everybody to click the button to install the new version. Never heard about any problems, but they may not have many wp users.
    Thanks… Miles

    jonimueller – I agree with Firas. Top idea !

    stengazette – you would be amazed at the number of errors caused by faulty overwriting. Given that deleting the old files takes but a few seconds, it’s worth doing. I would also never trust ANY host that says to upgrade with one click – that puts everything at risk of being changed.

    villas – I have edited the post above. Sorry !

    *red face* I upgraded two installs just now and one was fine while the other… isn’t. I deleted the wp-config on the bad one accidentally and in trying to recreate it, I’m just not having any luck. I don’t recall installing any plugins that should come into play so I copied the good version over and put in the correct values for the four fields. Still, I get the same message:

    “Error establishing a database connection”

    Now I have phpMyAdmin on the server so I checked and the user and wp database, with all the tables, are still there. Any suggestions?

    ' villas - I have edited the post above. Sorry ! '

    Thanks Podz .

    Make sure that the username and password in wp-config.php are exactly as you typed when using phpMyAdmin.

    Makes sure you’re uploading via FTP in ASCII mode.

    On a related note: I’m about to upgrade, because I use a large number of plugins it normally take me longer than most experiance. (Yes it’s my problem).

    I’ll ask here something that that I have posted on the mosquito but will again in the off chance one of the devs will see it.

    Can a function be added that allows a checkbox for enabling and disabling plugins? While I’m far from being a coding geek it would seem to be a simple addon or plugin, any takers?

    I’m with you, Marc. On one of my sites, I’m “down to” only 22 plugins used 😉 Disabling them takes twice as long as actually upgrading.

    Make that three of us: a global disable/enable for plugins would be SUPERB!

    I’m a bad boy, I just leave the “lights” plugged in and hope for the best.

    I did that one time, Beel, and all heck broke loose. I actually forgot this time and (thankfully) nothing bad happened. *whew*

    Um. Yeah, I do a “beel” mostly too…. so far I’ve been “safe”, but I’m bound to have problems eventually….

Viewing 15 replies - 16 through 30 (of 94 total)
  • The topic ‘NEW: Upgrade to 1.5.2’ is closed to new replies.