Support » Plugin: PublishPress Content Calendar and Notifications » New upgrade breaks server

  • Resolved easyco

    (@easyco)


    I just upgraded to the latest minor version and my log is filling up until my server 500s.

    Here’s a snippet of the logs:

    `
    [14-Mar-2018 03:35:56 UTC] WordPress database error Duplicate entry ‘2716-96’ for key ‘PRIMARY’ for query INSERT INTOnrw_term_relationships(object_id,term_taxonomy_id) VALUES (2716, 96) made by require_once(‘wp-admin/admin.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, publishpress->action_admin_init, PP_Roles->upgrade, PP_Roles->convertLegacyPostFollowingUserGroupsToRoles, wp_set_post_terms, wp_set_object_terms
    [14-Mar-2018 03:35:57 UTC] WordPress database error Duplicate entry ‘2718-96’ for key ‘PRIMARY’ for query INSERT INTO nrw_term_relationships (object_id, term_taxonomy_id) VALUES (2718, 96) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, publishpress->action_admin_init, PP_Roles->upgrade, PP_Roles->convertLegacyPostFollowingUserGroupsToRoles, wp_set_post_terms, wp_set_object_terms
    [14-Mar-2018 03:35:57 UTC] WordPress database error Duplicate entry ‘2719-94’ for key ‘PRIMARY’ for query INSERT INTO nrw_term_relationships (object_id, term_taxonomy_id) VALUES (2719, 94) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, publishpress->action_admin_init, PP_Roles->upgrade, PP_Roles->convertLegacyPostFollowingUserGroupsToRoles, wp_set_post_terms, wp_set_object_terms
    [14-Mar-2018 03:35:57 UTC] WordPress database error Duplicate entry ‘2720-96’ for key ‘PRIMARY’ for query INSERT INTO nrw_term_relationships (object_id, term_taxonomy_id) VALUES (2720, 96) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, publishpress->action_admin_init, PP_Roles->upgrade, PP_Roles->convertLegacyPostFollowingUserGroupsToRoles, wp_set_post_terms, wp_set_object_terms
    `

    Please help!

    • This topic was modified 1 year, 10 months ago by easyco.
Viewing 4 replies - 1 through 4 (of 4 total)
  • I too am seeing that the new update breaks WP and gives you the WSOD (white screen of death). If you rename the folder in /wp-content/plugins/publishpress, at least you can get your site back online.

    Hopefully a quick fix is imminent.

    Plugin Author andergmartins

    (@andergmartins)

    Hi,

    Thank you for reporting this issue.
    Please, accept our apologies, for this serious issue.

    I’m working on a fix and will contact you soon.

    Kind regards,

    Plugin Author andergmartins

    (@andergmartins)

    Hi,

    I rolled back the release to 1.10.0 again.

    Please, restore it to 1.10.0 replacing the current folder using FTP.

    You can download it from here: https://github.com/OSTraining/PublishPress/releases/download/1.10.0/publishpress-1.10.0.zip

    The issue was related to a deep refactoring we did on the plugin to improve the use of roles and capabilities. But the method to migrate the current data had a bug we weren’t able to reproduce locally. But after updating it affected our site as well.

    We are really sorry for this inconvenience. We are working to make sure the next release will fix the issue and do not break your site again.

    Please, let me know if you need anything else,

    Kind regards

    Plugin Author andergmartins

    (@andergmartins)

    I’m closing this ticket since reverting the plugin to the last stable version (link attached) works as a workaround. The fix for the bug are being developed and will be added to the next release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘New upgrade breaks server’ is closed to new replies.