• Resolved DodgeThat

    (@dodgehat)


    Your new update has broken the websites cart and checkout page. Here is the screenshot of the fatal errors. Unfortunately, we have to roll back.

    Let us know once this is fixed so we can test.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Brett Porcelli

    (@bporcelli)

    Thanks, looks like a PHP 8.1+ compatibility issue. Will look into a solution ASAP.

    Thread Starter DodgeThat

    (@dodgehat)

    Hello, I do not have a roll back version and my site is broken. It is currently in maintenance mode. What do i do? Do you have a link to the previous version?

    • This reply was modified 9 months, 3 weeks ago by DodgeThat.
    • This reply was modified 9 months, 3 weeks ago by DodgeThat.
    Thread Starter DodgeThat

    (@dodgehat)

    I saw the 8.0.1 update and updated the site. Error is still the same as the image above. Site is broken in this update as well.

    Thread Starter DodgeThat

    (@dodgehat)

    Can you send a link to the rollback. We receive orders on the fly, I cannot afford to leave the site down.

    Thread Starter DodgeThat

    (@dodgehat)

    NEXT TIME PLEASE DON’T PUSH PLUGIN UPDATES WITHOUT FIRST TESTING THEM OUT. THIS IS RIDICULOUS!!!!!!!!

    Thread Starter DodgeThat

    (@dodgehat)

    I changed the file Serializable.php to the file before the 8.0.0 update and no longer get errors. File location: \simple-sales-tax\includes\vendor\bporcelli\php-taxcloud\lib\TaxCloud

    Same problem on our site.

    Same problem here. Where can we get access to previous versions?

    @dodgehat @adam7hansen I put up a previous version that fixed our site that I got out of a backup of ours if you are interested. I just went into the broken site, deleted the current plugin, and uploaded the previous versions zip as a new plugin and it fixed our issues and retained our TaxCloud settings.

    Here is the link if you are interested.

    https://drive.google.com/file/d/1wxg1vpLM-7OeOTpwl-rA2OgM1KO2Y66a/view?usp=sharing

    Thread Starter DodgeThat

    (@dodgehat)

    @spencersmith Thank you for the link. However for now, I have fixed the current version temporarily until the next stable version is released. I requested @bporcelli to provide the version before 8.0.0 which is 7.0.13 to rollback to, but haven’t received any response.

    He can reply to my first message above, but cannot respond with a simple link to the rollback version.

    The new version 8.0.1 also breaks the ‘Add Certificate’ and ‘Manage Certificates’ on the checkout page. I disabled this feature for now under Exemption Settings – “Enable Tax Exemptions?”. So, now my customers cannot login and add their sales tax exempt certificate at checkout, which was working great in 7.0.13.

    @dodgehat I am glad you got it worked out! The version in the link I provided is Version 7.0.12.

    This is very frustrating and my clients are saying they want to move away from TaxCloud all together because of this issue and a previous issue a few months ago with the API throwing errors.

    I am trying to convince them to be patient… but its not working haha.

    Thanks @spencersmith. Your 7.0.12. version worked for me.

    Plugin Author Brett Porcelli

    (@bporcelli)

    @spencersmith @adam7hansen @dodgehat I had difficulty reproducing this locally but was ultimately able to do so. Based on my testing v8.0.2 should resolve the problem.

    I totally understand the frustrations re. instability with the plugin and I’m sorry I didn’t catch this in the testing cycle. The reason this went undetected in this case is it only occurs with specific PHP versions and our automated testing regrettably doesn’t cover all PHP versions currently. I will work to fix that before the next release so a PHP version specific issue like this can’t slip through the cracks again.

    I have been following this issue, and delayed updating the plugin because doing so was causing the error when a user tried to go to the cart on my staging site. Now that issue is resolved, but the tax exemption option is now causing issues. When I am on the checkout page, where it used to give me a checkbox for tax exempt and then allow me to choose my exemption certificate it now shows a dropdown box that allows me to choose my certificate. However, selecting the certificate doesn’t take off the tax. When I select “Manage exemption certificates” it takes me to my account page, with a button that says “Add Certificate”. Clicking that button does nothing but reload the page. We cannot update the plugin until these issues are fixed; please advise. Edited to add that the version with the working exemption is Version 7.0.13.

    • This reply was modified 9 months, 2 weeks ago by dwebsmith.
    Plugin Author Brett Porcelli

    (@bporcelli)

    @dwebsmith I am unable to reproduce either of these issues with the latest version of SST. Tried with a couple popular themes including Storefront and Astra. Will follow up in the other thread so we can continue the conversation there and hopefully pin down the conditions for reproducing the issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘New Update (Version 8.0.0) broke Website’ is closed to new replies.