Support » Plugin: Async Social Sharing » New Update to Async Crashed Whole Site

  • Resolved dbooth

    (@dbooth)


    We updated the Async Social Sharing plugin and immediately afterwards, the entire site crashed. We were unable to get to the admin area or even view the front pages.

    The error that displayed said something about a problem in one of Async’s files. Unfortunately I didn’t think to copy down the error listed, I was too frantic trying to find a way to disable Async.

    I had to enter the database to disable the plugin, and we will be keeping it disabled for the time being.

    https://wordpress.org/plugins/async-social-sharing/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Rachel Baker

    (@rachelbaker)

    Gosh. I am sorry to hear about the effect the plugin update had on your site. I would like to be sure no other users of the plugin have the same experience, but I have not been able to reproduce it in testing.

    Can you share the version of WordPress, and list the theme and plugins active on your site?

    wittonline

    (@wittonline)

    I have the exact same issue.

    I just updated all my plugins on a new site http://www.projectfreedomblog.com using 3.9.1. I don’t remember the theme and can’t check it now of course. Maybe Clean Retina or Catch Box.

    Error Code: Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or ‘$’ in /home/content/28/9856828/html/projectfreedomblog/wp-content/plugins/async-social-sharing/async-share.php on line 53

    Here’s a list of all the plugins that I just updated all at once:

    Async Social Sharing
    You have version 1.7.1 installed. Update to 1.8.0. View version 1.8.0 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    BotDetect CAPTCHA
    You have version 3.0.Beta1.7 installed. Update to 3.0.Beta3.3. View version 3.0.Beta3.3 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    Jetpack by WordPress.com
    You have version 3.0.1 installed. Update to 3.0.2. View version 3.0.2 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    Livefyre Realtime Comments
    You have version 4.1.2 installed. Update to 4.1.4. View version 4.1.4 details.
    Compatibility with WordPress 3.9.1: Unknown

    NextScripts: Social Networks Auto-Poster
    You have version 3.3.7 installed. Update to 3.3.9. View version 3.3.9 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    Optin Revolution
    You have version 1.3.5 installed. Update to 1.3.7. View version 1.3.7 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    Sweet Captcha
    You have version 3.0.6 installed. Update to 3.0.8. View version 3.0.8 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)
    Compatible with WordPress v3.9.1, Gravity Forms and Buddypress support

    WordPress SEO
    You have version 1.5.3.2 installed. Update to 1.5.3.3. View version 1.5.3.3 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    WP to Twitter
    You have version 2.8.8 installed. Update to 2.8.9. View version 2.8.9 details.
    Compatibility with WordPress 3.9.1: 100% (according to its author)

    Plugin Author Rachel Baker

    (@rachelbaker)

    wittonline,

    Thank you for the error report. I have just released version 1.8.1, which fixes the plugin bug causing PHP 5.2 (or lower) to error.

    I apologize to you and dbooth for causing panic and frustration from the 1.8 update on your site. I appreciate you both taking the time to report the issue.

    1.8.1
    * Fixed bug where plugin would cause a fatal error for PHP 5.2 and under by changing class initialization process.
    * Added minor style fix for Facebook sharing widget alignment.

    wittonline

    (@wittonline)

    Thanks Rachel!

    Real quick, I’m sure I can figure it out, but for SE visitors can you post instructions to install the update without access to the wp-admin, since it won’t be accessible.

    dbooth

    (@dbooth)

    Thanks! This latest update has fixed the issue for me as well.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘New Update to Async Crashed Whole Site’ is closed to new replies.