Support » Plugin: Popup Maker - Popup Forms, Optins & More » New update stops cornerstone from working

  • Resolved njones7

    (@njones7)


    1. http://www.ptnu.com.au
    2. When loading cornerstone to edit pages it should be able to load the whole page for editing
    3. Only loading header and footer, content is missing

    I disabled all my plugins and enabled them one by one and found that popup maker was causing cornerstone to not working properly, rendering me unable to edit pages.I want to be able to keep using popup maker though as it is useful for many key components of my website.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author danieliser

    (@danieliser)

    @njones7 – Sounds like a JS error on the page preventing their editor from starting. Check your browser console for those and let us know.

    5 errors and 37 warnings… not sure what exactly im looking at though

    Plugin Author danieliser

    (@danieliser)

    @njones7 – errors that don’t involve 404 or missing resources etc. Also please click the black arrow showing more details for any errors that are relevant.

    Ok so there is wayy too many warnings to list them, but there are some errors.

    Uncaught Syntax Error: Unexpected end of input
    Uncaught Syntax Error: Unexpected token
    InvalidValueError: not an instance of HTMLInputElement

    Uncaught ReferenceError: pum_shortcode_ui is not defined
    at new <anonymous> (mce-buttons.min.js?wp-mce-4607-20180123:1)
    at k (tinymce.min.js?ver=4607-20180123:13)
    at Array.<anonymous> (tinymce.min.js?ver=4607-20180123:13)
    at Object.b [as each] (tinymce.min.js?ver=4607-20180123:1)
    at m (tinymce.min.js?ver=4607-20180123:13)
    at Object.r [as init] (tinymce.min.js?ver=4607-20180123:13)
    at q.<anonymous> (tinymce.min.js?ver=4607-20180123:13)
    at Array.<anonymous> (tinymce.min.js?ver=4607-20180123:3)
    at b (tinymce.min.js?ver=4607-20180123:1)
    at r (tinymce.min.js?ver=4607-20180123:3)

    Plugin Author danieliser

    (@danieliser)

    @njones7 – Ok so that error specifically means your server likely uses nginx with heavy front end caching for assets. What this means is that your server is aggressively caching the old version of that file. We can easily verify this by loading that file directly in the browser with the ?wp-mce-4607-20180123 on the end which will include code like pum_shortcode_ui which will cause errors. If you load the same file without the ?wp-mce-4607-20180123 it will show the new version of pum_shortcode_ui_vars

    It causes an error because the new version changed that variable name, but your still running the old version.

    We have a fix coming in v1.7.12 by adding ?version={Current Popup Maker Version} to our urls to force it different every version.

    Hope that helps.

    Hey, so I am unable to see that error now (if i recall correctly) but I am still unable to edit pages in cornerstone, there are other warnings and errors i am getting but i’m not sure what ones relate to popup maker or how to fix them. I dont like having to deactivate your plugin every time i want to edit a page, especially how much i rely on it.

    I have this issue as well. Disabling Popup Maker fixes the issue. The console doesn’t have any errors. Not sure why this issue is marked as resolved. It is not.

    • This reply was modified 1 year, 2 months ago by  Roy McKenzie.

    I still haven’t been able to resolve this either, if i cant resolve it i might have to swap over to a different plugin (id rather not have to take this path)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘New update stops cornerstone from working’ is closed to new replies.