Support » Plugin: Bitcoin Payment Gateway for WooCommerce » New update : Legacy segwit problem !!

  • Resolved salmalouch

    (@salmalouch)


    Hello so i did the update and regretted
    i lost 60 euro like that normally when i used the plugin first time i was using segwit electrum wallet generated BC1 address i got feedback that lot of service reject segwit address then went to legacy address start with 1 everything was fine plugins soo good
    until i made update and now address are generated only segwit BC1 i tried legacy and newsegwit nothing only generate bc1 and i dont even know where that address is
    https://i.imgur.com/BdEz21P.png
    https://i.imgur.com/w5e9keU.png
    Address and wallets i tried
    and this is what i get in my shop
    https://i.imgur.com/eHZ6NzM.png

    Please advise ?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter salmalouch

    (@salmalouch)

    I tried to use previous version until this get resolved but i get error processing order

    Plugin Author Triple-A.io

    (@tripleatechnology)

    Hi @salmalouch ,
    Apologies for the delay in getting back to you.
    We were looking into your issue.

    1. it seems you created 4 accounts through our plugin, for different public keys.
    2. you most recently created a new account, but our API response sent back several of your accounts so the plugin seems to have picked the wrong one.
    3. your funds have been sent to one of your accounts but not the one you most recently tried to create.

    We will release a fix by wednesday. Until then:
    – you should see all of your accounts in the TripleA dashboard (top left, select an account to see the transactions) to verify your payment did arrive safely 🙂
    – please try to access the previous wallets you created, confirm with us that you still have access to it.

    If you don’t have access to the previously created wallet that received the funds, remove and reinstall the plugin, then use a new master public key with a new email address. This multi-account bug will not occur and no issue will happen.

    This is an error on our part. We will do our best to resolve this ASAP and make certain you did not end up losing that payment.
    Meanwhile, either disable the plugin or follow the above steps.

    We will get back to you very soon.
    Regards,
    TripleA Team

    Plugin Author Triple-A.io

    (@tripleatechnology)

    Hi @salmalouch ,
    We have patch version 1.5.0.
    You would have to remove and re-install the plugin, rather than just updating (which is why we did not update version number to 1.5.1).

    When creating OR upgrading an account it will now correctly use the just created or previously existing account.

    Let us know if it goes smoothly for you now?
    Regards,
    TripleA Team

    Plugin Author Triple-A.io

    (@tripleatechnology)

    Hi @salmalouch ,
    Haven’t heard back from you. I will close this as resolved because the bug was fixed, however please confirm with us if everything is sorted out on your end.
    If not, our team will assist you by email until it’s all clear or settled.

    Regards,
    TripleA Team

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘New update : Legacy segwit problem !!’ is closed to new replies.