Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » New update kills random picture widget

  • Resolved SFrueh

    (@sfrueh)


    Newest WP version, newest NG version, Theme twenty-eleven

    Hi there,

    todays NextGEN update froze the NextGEN widget, that shows recent or random images from the galleries.
    I use the widget to show ten random pictures on my front page.

    Todays update broke the widget. Now it shows the exact same ten pictures to everyone. It does not refresh anymore.

    Before you ask: Yes, I did
    – check if the widget is still set on random pictures and not on recent (it is)
    – try different browsers
    – clear the browser cache
    – try smartphone

    There was no effect. The widget does just not work anymore. Before todays update the widget worked fine for six years.

    Help appreciated.

    Greetings,

    SFrueh

    • This topic was modified 1 year, 9 months ago by SFrueh.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 16 through 20 (of 20 total)
  • And here’s the most confusing part – I can switch to Recent and get different photos, then go back to Random and I get the SAME photos from when it was previously set to random. So 3.1.5 does NOT fix the random cache issue.

    Plugin Support edanzer

    (@edanzer)

    Hey all – just a quick update. The latest release does change some implementation for random galleries. We ended caching of random galleries on individual pages or posts. As of now, we are still caching random galleries for 30 minutes for widgets. So for widgets, you’ll get a fresh batch of images every 30 min or so.

    We are talking about adding an option to turn that off for widgets, so widgets would return to their prior behavior of no caching.

    As I think I’ve laid out, one major point to make: the use of true randomized widgets in the side bar is a major performance issue. The function call needed to go through all your images and select a random batch is costly, and when you put that random widget on the sidebar, that call is made every time any visitor loads any page on your site. If you have any substantial traffic, the cumulative cost of all those calls can be a major performance drain.

    That’s the reason we’re still caching the widget. We’ve lowered the amount of cache time to 30 minutes, but that’s still plenty to prevent the performance drain.

    The next step will be to add an option to turn off that caching. It’ll come with a performance warning though. We did consider alternative ways of ‘faking’ random galleries, but there were some implementation concerns for each approach we considered. Right now, we’re not looking at that.

    For those of you wanting true random galleries via widget area – I assume you’d still continue to use them if we added the option, despite the performance concerns above?

    FYI – if you’ve been using them in the past, you’ve been encountering the performance consequences already, and just weren’t aware. That’s why we fixed / adjusted it as we did. We’ve assumed performance > true random widgets.

    Note again: we are not caching random galleries on pages or posts, because the effects of the random function calls don’t repeat on every page load site wide, and thus don’t have the same performance drain.

    Thank you for the update. This is the answer I needed. Perhaps we can have the option to set the length of the cache as that would be more useful than just turning it on or off.

    Plugin Support edanzer

    (@edanzer)

    @grandslambert – Yup, good point and I’d agree.

    @grandslambert Sorry to hear that. Random galleries are working for us after the last update. Perhaps some other page caching is going on?

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘New update kills random picture widget’ is closed to new replies.