Support » Plugin: OSM - OpenStreetMap » New Update has broken the maps

  • Resolved DrMilhouse

    (@drmilhouse)


    Hello,
    today I updated the OSM-Plugin.
    And now no maps are shown. Instead of maps, there is only the text: “You have to accept cookies and load of third party data to see map”.

    This would be no problem, if the plugin would give a possibility to do this.

    Perhaps it only happens, if I am logged in, but I have to figure this out.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I have the same problem with Chrome browser.

    But I have a different problem with Firefox: I see the popup described above for about half a second and then I see the map without markers.

    • This reply was modified 7 months, 1 week ago by theophilix.
    • This reply was modified 7 months, 1 week ago by theophilix.
    • This reply was modified 7 months, 1 week ago by theophilix.
    Thread Starter DrMilhouse

    (@drmilhouse)

    First try was Opera, like describes in first post.

    Logged in: Just the error message.
    Guest: See error text for half a second, after it map correctly with marker

    I tried again with Firefox, Chrome, Vivaldi and Edge:

    If I am logged in or not logged in:

    See text for perhaps a second, after see map correct with markers.

    Plugin Author MiKa

    (@photoweblog)

    Hello @drmilhouse

    thank you for your feedback. The image you mentioned is the background image.

    There are a couple of reasons for not showing the map:
    * Javascript not loaded
    * tile server is down
    * a bug in the update
    * conflict with other WP plugins
    * …

    Post a link to your site that fails. If you do not want to post your site here, you can also send it via the contact page:#

    https://wp-osm-plugin.hyumika.com/contact/

    Br, Michael

    • This reply was modified 7 months, 1 week ago by MiKa.
    • This reply was modified 7 months, 1 week ago by MiKa.
    danielemana

    (@danielemana)

    Has anyone found a solution?

    Plugin Author MiKa

    (@photoweblog)

    We are working on an update that should fix this. Will be released this week.
    Br, Michael

    Plugin Author MiKa

    (@photoweblog)

    Hi @drmilhouse ,

    let me know if v5.9.1 fixed the issue.

    Thanks & br, Michael

    Thread Starter DrMilhouse

    (@drmilhouse)

    Hello,

    thanks for the update.

    It still shows the message for half a second and than the map. So no real solution. The message seems to be the background, cause if I move the map very fast, i see the message shining through.

    Plugin Author MiKa

    (@photoweblog)

    Hello @drmilhouse

    thanks for the feedback.

    These are two different topics:

    1.) showing the map not at all
    2.) showing the map after some time

    This thread addressed issue 1.) which should solved now.

    For issue 2.) several other komponents need to be checked. Could be from a slow tile server to a conflict on the WP installation. In any case it’s not a matter of “New Update has broken the maps” – so pls open a new thread for it.

    Thanks & br, Michael

    Thread Starter DrMilhouse

    (@drmilhouse)

    1. First problem solves itself today, before update.

    2. So why easy if there is a complicated way…

    Plugin Author MiKa

    (@photoweblog)

    Hello @drmilhouse,

    thank you for opening a new thread for the new issue.

    Br, Michael

    danielemana

    (@danielemana)

    Thanks for the update, but not resolve the problem for my site.
    After update to v. 5.9.1 and clean all caches, dont’t show the map…

    Wordpress v. 5.8.2
    yootheme v. 2.7.4

    Daniele

    Plugin Author MiKa

    (@photoweblog)

    Hi @danielemana,

    post your osm-shortcode and a link to the post/page.

    If you do not want to post your site here contact us here:

    https://wp-osm-plugin.hyumika.com/contact/

    Br, Michael

    OSM Map showing on Firefox, but not on Chrome, Opera or Edge.
    Version: OpenStreetMap Plugin V5.9.3
    [osm_map_v3 map_center=”48.1709,11.3237″ zoom=”18.0″ width=”95%” height=”450″ post_markers=”1″ control=”fullscreen”]

    https://www.kaffee-werkstatt.eu/kaffeevollautomaten-reparatur/kaffeemaschinen-reparatur-muenchen/

    Any suggestion?

    Joerg

    After switching off all other plugins: The map is showing.
    After that: The Cache-Plugin WP Rocket caused the problems.
    I will get back with them to find out how to set up WP Rocket so that it does not interfere with OSM.

    Br, Joerg

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.