Support » Plugin: WP Hide Post » New update errors

  • Hi,

    After a new update I get error incontrol panel:

    ...nt/plugins//wp-content/plugins/wp-hide-post/wp-hide-post.php): failed to open stream: No such file or directory in /wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4791

    I changed my hosting to php 7 and it didn’t help. I cant just turn off this plugin because I have a lot of posts hidden. Please help if you can.

Viewing 6 replies - 16 through 21 (of 21 total)
  • Indeed. Now the plugin seems to not break on activation, however it still doesn’t with an error:
    Parse error: syntax error, unexpected ‘[‘ in /home/<user>/domains/<domain>/public_html/blog/wp-content/plugins/wp-hide-post/admin/settings/class_settings.php on line 332

    Plugin Author scriptburn

    (@rmahfoud)

    @kulverstukas you need to update to php to at least 5.5 for this error

    @scriptburn: welp that sucks a bit. I’m on a shared hosting, can’t do that myself.
    In the changelog I see you’ve been addressing some compatibility issues, but I tried versions down to 2.0.2 and it still doesn’t work, and that’s as low as I’m willing to go.
    My host is using PHP version 5.3.28. Can there be done anything about that?

    EDIT: scratch that. Didn’t see the latest (2.0.8) version. That one seems to work. Thank you!

    • This reply was modified 4 years, 10 months ago by Kulverstukas.
    • This reply was modified 4 years, 10 months ago by Kulverstukas.
    • This reply was modified 4 years, 10 months ago by Kulverstukas.
    Thread Starter kubeq130

    (@kubeq130)

    Can you share with me a previous version to download? I tried everything. Plugin seems to work ok, but I can not get rid of those errors in my admin panel.

    I’m not sure that I want to show you my ftp.

    I unchecked all articles from your plugin, deleted plugin, uploaded it to ftp server manually and still error. I tried to download automatically from admin panel and still the same error.

    @kubeq130: previous version can be obtained by changing the version name in a URL where you download the latest version: https://downloads.wordpress.org/plugin/wp-hide-post.2.0.8.zip

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @rmahfoud I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://make.wordpress.org/support/handbook/forum-welcome/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘New update errors’ is closed to new replies.