Support » Plugin: Disqus Comment System » new update error on console

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi there,

    Could you provide a link to a page where this error can be seen, as well as the browser/OS/devices that you’ve seen it on?

    Thread Starter vl4d

    (@vl4d)

    all the browsers i test (chrome/firefox/tor/opera/edge all lastupdated) OS win 10

    and the error is only in the post/page(homepage) the comments is disabled if this means something, in the post with the comment open is ok.

    Thread Starter vl4d

    (@vl4d)

    so the fix for that is plugins/disqus-comment-system/public/js/comment_embed.js

    (function() {
    	if(document.getElementById('disqus_thread')) {
    		var dsq = document.createElement('script');
    		dsq.type = 'text/javascript';
    		dsq.async = true;
    		dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
    		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    	}
    })();

    i change the element id from script to disqus_thread..

    @vl4d Can you please elaborate on your fix? I’m seeing this exact same error on a site of mine as well after updating to WordPress 5.6+

    @disqussupport You can see the error on my site here – https://www.specialolympicswisconsin.org/

    @vl4d Ah I see, they just need to add a check to see if the current page has a disqus_thread before running the code. I opened that file and see you just added the conditional check for document.getElementById('disqus_thread')

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘new update error on console’ is closed to new replies.