Support » Plugin: W3 Total Cache » New update didn't work…W3 Total Cache Error: Files and directories could not b

Viewing 15 replies - 1 through 15 (of 18 total)
  • I receive the exact same error.

    I want to revert to the previous version since this one is totally [removed by moderator] up. It keeps messing up my .httaccess…where can I downgrade to the previous version of w3 total cache???

    I retrograded to v0.9.2.9 and everything is sweet again.
    To get the previous versions, you go to the where the plugin is listed on wordpress.org and under the developers link, you can download any of the previous versions that you want to.
    P.S. make sure you uninstall the plugin before install the one you download.

    Ahh, much better. Thank you!!

    KevinG

    (@superfastwhiteboy)

    I was attempting to do a fresh install on a new site and received the same error messages. Uninstalled and reinstalled v0.9.2.9 and everything is fine. Hope they figure this out.

    That’s more than my dashboard showed. When I clicked on the FTP “Update via FTP” I got a blank box.

    After reverting to v0.9.2.9 things are back to normal.

    Make sure you guys post something in the support area for the plugin so the developer knows the issue:

    http://wordpress.org/support/plugin/w3-total-cache

    This is one annoying plug-in. I try to uninstall it in order to install previous version and all I get is an error:

    “W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.
    Please execute commands manually
    or use FTP form to allow W3 Total Cache make it automatically.”

    It shows this error twice, one on top of the other..

    I have deactivated W3 until I figure out how to fix it. To be honest I just want it uninstalled and gone.

    With it deactivated my site still seems fast enough..Do you think I should just leave it deactivated?

    Also, would it be ok to install the super cache plug-in even though W3 is not uninstalled, but deactivated?

    I’m also getting this error, except it’s:

    FTP credentials don’t allow to write to file /.htaccess

    Anybody have a fix yet?

    Jen

    (@brightestspark)

    I get the same error as nathanlambert since last update.

    FTP credentials don’t allow to write to file /.htaccess

    The plugin author helped me out and he said the issue is that the plugin cannot figure out the proper file path to the file. He told me to talk with my host so they can set up ‘typical DOCUMENT_ROOT, SCRIPT_FILENAME, PHP_SELF and similar constants’.

    I’m using hosting through Hostpapa, btw. They are awful though, so I wouldn’t mind moving to a different host.

    Hi!
    I’m getting the same error.
    ANY SOLUTIONS YET?

    Looks like you have to pay for any kind of support. Probably thats why the dashboard is full of options how to pay for config. This is definitely not out of the box solution, it is more like a dangerous plugin.

    Those errors are not a plug in fault, but hosting service (mis)configuration and thus giving you even less writing privileges than a regular shared hosting provider should.

    Inability to write to stuff like .htaccess is bad if it’s not your choice.

    To see whose fault is it, use your FTP program to change the writing privileges on .htaccess (and the other problem files) to 664. If you get an “access denied” or “not enough privileges to…” then your hosting service has restricted you too much.

    If your FTP program succesfully change to 664 (which means: Write (owner) Write (Group) Read (Everyone) then it was you who did something wrong and write protected the files. W3 TC is not to blame.

    W3 TC indeed is a very delicate plug in that requires either a good hosting provider or (and) knowing some more technicalities than the general WordPress plug in usually requires.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘New update didn't work…W3 Total Cache Error: Files and directories could not b’ is closed to new replies.