Support » Plugin: WordPress Portfolio Plugin (WP Portfolio) » New update changed my columns

  • Resolved DelCKS

    (@delcks)


    Hi Pura,

    The latest WP-Portfolio update kind of reset my plugin. All my custom layout settings were default again. I did manage to figure that out though.

    It does seem like the column setting has changed. I didn’t have column settings up until now. The site just filled the thumbs from left to right. If I don’t use the column settings, I only get one column now. And the column setting doesn’t take me past 4 columns, everything above that just shows 1 column.

    Could you help me out please? I’ve got the Extra Large Thumbs now, to fill up the space. They should have been the Small ones.

    DelCKS
    http://m.vonsuri.com/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author puravida1976

    (@puravida1976)

    Hello!

    No settings should be changed. If you could be more specific about that, I could report it to my developer helping me with this plugin.

    The most recent update included a change to the CSS to properly format the responsive layout (elastic grid) for defined columns. It did not cause any issues with our various test scenarios but with so many possible layouts, one of the changes must conflict with yours.

    To work with apples-to-apples, please use your layout to make a separate test page with the smaller screenshots. The grid layout will split the width evenly, so you won’t likely be able to just fill the space as wide as possible that way.

    If you can make a test page using the same previous settings, I can use developer tools on your exact layout and play around with the CSS to see how best to achieve the desired result.

    Best regards,

    Brandon

    Hi Brandon,

    The settings haven’t changed but the “Website HTML Template”, “Template CSS” and “Paging CSS” have been set to the default standard. And those options can be found at the Layout Settings, so those are the settings I mean.

    I can’t go back to the previous settings what the above is concerned but I did change back to the small thumbs and I removed the “columns=”4″” line.

    I didn’t create a test page. You can use the main page.

    Thanks!

    Best regards,

    Delmar

    Plugin Author puravida1976

    (@puravida1976)

    Hello Delmar!

    Thank you for the clarification. I will ask my dev to see why the template and CSS settings might have been overwritten. That is definitely not good.

    I also think that may have caused the formatting issue, because we did not seem to have any specific support that would fill up space automatically. The default is a single column and the grid layout adds 2, 3, & 4 column support. Could it be that you had custom CSS to do what you wanted and that was wiped out when the template/CSS reverted??

    After messing around a bit, I found that I could responsively fill the space with the screenshots with the following tweak to the “Template CSS”:

    .portfolio-website {
        float: left;
        padding: 0 1em;
    }

    Does that do what you desire?? If not, please elaborate on the desired end result. I am happy to help, and we’ll get there. 😉

    Best regards,

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    Hello Delmar,

    Regarding the settings override, I have confirmed with my developer that he DID set v1.42.3 to update those defaults, indiscriminately, in order to support the following:
    BUG FIX: Adjust default CSS for consistent handling of “responsive columns” (e.g. “elastic grid view”)

    After seeing your use case, we have decided to have the plugin check for any modifications to EACH of those custom areas and skip updating, if modified by the user.

    The upside is that the user’s Portfolio will most likely remain as-is after upgrading. The downside is that the user may not understand why the elastic grid 2, 3, and 4-column support widths are “off” somewhat (e.g. the point of the BUG FIX that needs to modify those settings to overcome the issue).

    Thank you for being vigilant and reporting this issue with detail. 🙂

    Best regards,

    Brandon
    p.s. Please let me know if my suggested “tweak” above helps point you in the right direction of getting things back the way you want them!

    Hi Brandon,

    Thank you! Your suggested tweak did the trick. Thanks for the inside info.

    Really appreciate you taking time for me. Keep up the good work!

    Best regards,

    Delmar

    Plugin Author puravida1976

    (@puravida1976)

    Hi Delmar,

    It was my pleasure! I am glad the tweak worked for you, and it makes me think we should add this tweak to the layout options for a future update.

    Take care and best regards!

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    If you haven’t already left a 5-star feedback and LOVE this plugin, please consider leaving an awesome review. 🙂

    https://wordpress.org/support/plugin/wp-portfolio/reviews/

    DelCKS

    (@delcks)

    Morning Brandon,

    Thanks for your support.

    I found something else that has changed. The Title Text under the thumbs (http://retmus.com/) isn’t being wrapped anymore. Any idea which part of code that is? Tried a lot of things but can’t seem to find it.

    Thanks in advance!

    Delmar

    Plugin Author puravida1976

    (@puravida1976)

    Hi Delmar!

    I’m not sure I understand. I just checked your site and see that the titles are all wrapped in the “website-name” DIV. Could you please clarify the issue??

    If you meant “word-wrap”, I’d have to ask my developer. I do not believe anything has changed with the CSS but perhaps it is related to your customizations getting wiped out during the last update (won’t happen again). That title is very short and doesn’t need to wrap, so I wasn’t sure if this was what you meant or not.

    Sincerely,

    Brandon

    DelCKS

    (@delcks)

    Hi Brandon,

    Sorry for not being very clear. I meant the “word-wrap” and sent the wrong link. This is it: http://retmus.com/english/

    Thanks in advance.

    Delmar

    Plugin Author puravida1976

    (@puravida1976)

    That’s a tough one. Must have been another customization you had that is gone now. I think it has to do with absolute positioning, but I’ve run out of time. The power here has been out for an hour and my batteries are running low. Having to shut down and wait until can get back online. Will update asap.

    Ciao,

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    Power finally restored. Continuing my testing… 🙂

    Plugin Author puravida1976

    (@puravida1976)

    Hello again,

    First, a a couple of quick notes:

    1. I noticed that your “Powered by” sub-footer floats up into the portfolio grid, which you probably do not want, now that we use float left. You should be able to put a <div style="clear:both;"></div> after the portfolio to correct that.

    2. Your headings are a little close to the portfolio row above them, but since margins do not seem to work there; you would need to clear:both before each one (then add the margin-top:10px;) or you could use the “quick fix” below for the text wrap issue (which also fixes the spacing).

    Now for the issue at hand:

    Here is a “hack-ish”, quick fix…

    .portfolio-website {
        float: left;
        padding: 0 2px 15px 0;
    }
    .website-name {
        font-size: 9pt;
        margin-bottom: 0px;
        text-align: center;
        position: absolute;
        width: 200px;
    }

    However, I don’t really like this quick fix, because it’s basically hard-coding the width of the text area. So, I’m going to engage my developer for the plugin and get his feedback too. Perhaps he will have unique insight, in case he did make a CSS change that I don’t realize. Will get back to you shortly.

    Cheers,

    Brandon

    Plugin Author puravida1976

    (@puravida1976)

    Hello Delmar,

    I heard back from my developer, and he reviewed the issue and the code. He agrees that you must have had a customization that set the width before.

    The bad news is that there does not appear to be any way to avoid hardcoding the width, unfortunately.

    The good news is that he found a more elegant solution that will work in more cases, does not require hardcoding the height via the padding, and avoids the use of absolute positioning. His method also eliminates the use of the float:left, so that negates the need for the CSS hacks to fix your pre-footer iframe text and also fixes the spacing for the H3 headings.

    So, his method is to simply update the main portfolio-website DIV as follows:

    .portfolio-website {
        display: inline-block;
        vertical-align: top;
        padding: 0 2px;
        width: 226px;
    }

    I tested this and it looks good, works well, and remains responsively filling in the grid.

    Cheers!

    p.s. If you haven’t already left a 5-star feedback and LOVE this plugin, please consider leaving an awesome review. 🙂

    https://wordpress.org/support/plugin/wp-portfolio/reviews/

    DelCKS

    (@delcks)

    Hi Brandon,

    Thank you! That did the trick. Not much more I can say, you rock! Keep up the good work and thanks a bunch. Really appreciate the effort and solutions.

    I am happy! Have a great weekend!

    Delmar

    ps Can’t find the “Donate now” PayPal button 😉

    • This reply was modified 6 months ago by  DelCKS.
Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘New update changed my columns’ is closed to new replies.