• Resolved joalmoore

    (@joalmoore)


    I updated WC Vendors (free) this morning and I’m getting the white page back on homepage. I also update the theme that I’m using. Debugging gives this error back: Fatal error: Call to a member function get_option() on null in /home/joalmoore/public_html/thezaffre.com/wp-content/themes/rehub/inc/wcvendor/wc-vendor-free-brand/class-shop-branding.php on line 41

    Is this error the theme or wc vendors?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • I forgot to mention that when I deactivate WC Vendors with my current theme the site works but on the flip side when I activate it but install a new theme the site also works. It seems the site isn’t working with my theme and wcvendors together anymore. I can’t determine which one is causing the problem.

    Plugin Author Jamie

    (@digitalchild)

    Hello,

    Your theme will need to be updated to support the new settings system. I contacted Rehub developers a couple of months ago via the contact form on theme forest and never got a response.

    You will need to inform the Rehub developers of these changes as they don’t seem to pay attention to my updates.

    cheers,

    Jamie.

    Ok, I updated both WCVendors and my theme this morning. This is the first time this has happened with using these two together. All other updates have caused no problems. I’ll leave a comment for them with the error message and see what I get back. Thanks

    Plugin Author Jamie

    (@digitalchild)

    Hello,

    Yes I apologise, the changes were significant and not possible for me to make them backwards compatible. This is why I tried to put a big notice to get people to get these updates on a staging server before hand.

    I contacted as many developers as I could however some of them did not respond.

    cheers,

    Jamie.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    If you need support then per the forum guidelines please start your own topic.

    https://wordpress.org/support/guidelines/#post-in-the-best-place

    You can do so here.

    https://wordpress.org/support/plugin/wc-vendors/#new-post

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘New update causing white homepage’ is closed to new replies.