Support » Plugin: Cookie Information | Free GDPR Consent Solution » New update breaks Flatsome theme

  • Resolved Nellybongo

    (@nellybongo)


    Hi after automatic update today your plugin removes the menu bar from flatsome theme. please advise

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • I can confirm that. Plugin disabled till fixed.

    Is there a fix coming ASAP? I have dozens of broken clients websites…

    I believe you need to revise your css classes…

    Flatsome theme is using for example “.hide-for-medium” class, and you are using it like this:

    @media print,screen and (min-width:40em) {
     .hide-for-medium {
      display:none!important
     }
    }

    What hides various elements for any website that uses Flatsome theme…

    • This reply was modified 1 year, 1 month ago by Kramarz.
    • This reply was modified 1 year, 1 month ago by Kramarz.
    Thread Starter Nellybongo

    (@nellybongo)

    @kramarz Thank you, i have also taken this off all sites until a fix, but I will try this on one of the sites

    @nellybongo

    Thank you for raising this issue.
    We will take a look at what we can do in the short term to fix this.

    We’ll keep you posted about any updates.

    I have the same problem.
    I think it is not so good to use !important tag in CSS…and also to extend styling outside plugin context!

    @nellybongo
    Please update to version 2.0.2, the issue has been fixed.

    Thread Starter Nellybongo

    (@nellybongo)

    @van-ons Critical update error after installing v2.0.2

    Thread Starter Nellybongo

    (@nellybongo)

    @van-ons I have found that this plugin is affected when yours is active, s2Member Framework

    Thread Starter Nellybongo

    (@nellybongo)

    Here is the php error, ps removed URL

    AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /var/www/vhosts/httpdocs/wp-includes/capabilities.php:693\nStack trace:\n#0 /var/www/vhosts/httpdocs/wp-content/plugins/s2member/src/includes/classes/option-forces.inc.php(147): current_user_can()\n#1 /var/www/vhosts/httpdocs/wp-includes/class-wp-hook.php(305): c_ws_plugin__s2member_option_forces::check_register_access()\n#2 /var/www/vhosts/httpdocs/wp-includes/plugin.php(189): WP_Hook->apply_filters()\n#3 /var/www/vhosts/httpdocs/wp-includes/option.php(128): apply_filters()\n#4 /var/www/vhosts/httpdocs/wp-content/plugins/wp-gdpr-compliance/Integrations/WPRegistration.php(37): get_option()\n#5 /var/www/vhosts/httpdocs/wp-content/plugins/wp-gdpr-compliance/Integrations/AbstractIntegration.php(40): WPGDPRC\\Integrations\\WPRegistration->initHooks()\n#6 /var/www/vhosts//httpdocs/w...', referer:

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘New update breaks Flatsome theme’ is closed to new replies.