WordPress.org

Support

Support » Plugins and Hacks » WP eCommerce » [Resolved] New Update 3.8.14.1 does not solve the mess from 3.8.14

[Resolved] New Update 3.8.14.1 does not solve the mess from 3.8.14

Viewing 15 replies - 1 through 15 (of 40 total)
  • Plugin Author Mihai

    @misulicus

    Could you post a url so we can check it out ?

    Yes, it is:

    I made a rollback already, I’m not willing to loose customers!

    If there is somebody willing to work and test on it then I would make the update again. But only then.

    I’m having the same problem. I am using WordPress 3.9.1 and just upgraded WP E-Commerce to 3.8.14.1 http://www.campamerican.com. When I put in a test order and try to purchase through Pay Pal I get a refresh and a message “please enter a valid state” in the “Billing” section. When I put in a valid state (any state) the process repeats with the billing state disappearing.

    Any solutions?

    Plugin Author Justin Sainton

    @justinsainton

    Hi michaelisc,

    Taking a look at your site now – haven’t seen this specific issue in 3.8.14.1 elsewhere, so I’ll dig deeper and ask Jeff to do the same.

    I have the same issue as michaelisc. Continue to receive a “Please enter a valid province” message when checking out, even though a province is correctly added.

    This is absolutely ridiculous. My calculator hasn’t worked in days and I am losing business. This is not the first time I’ve had problems with my cart either. FIX the problem!

    Update- I disabled all plugins. This did nothing to solve the problem. I kept the cache program disabled and flushed the theme cache- nothing.

    Update- switched to 2014 theme. Problem persists.

    You might have the same issue I had – here is how my calculator problems were resolved:

    First off, I only am shipping to USA, so on the Shipping Tab, I have flat rate setting checked and $4 entered for “Continental 48 States”

    1. Store>Settings>Taxes “Tax Logic” radio button set to “Apply tax when Shipping Region is the same as Tax Rate”

    2. Store>Settings>Checkout – scroll down to “shipping”, grab and slide the “Country” field above the “State” field.

    3. For Shipping, make sure Country and State are checked to display.

    You might start with those settings just to see if it works that way for you.

    Many thanks, CF02.

    We’re selling tuition so there’s no shipping. Here’s what fixed it for me. Your suggestion to slide the country above the state did the trick. Seems odd that this would be so critical.

    Glad it worked! If your customers are only USA, you could set up shipping as I did on the shipping tab, then the Country will only show USA and customers will not have to scroll through all the other countries to get down to USA. Then on “Products”, edit your product by scrolling down and checking the box “Product will not be shipped”.

    These settings are what I use for taking payment for attendance at seminars.

    I am getting fatal errors on my check out!
    https://ada-grab-bars.com/products-page/checkout/

    Plugin Author Mihai

    @misulicus

    @jasondyork try flushing theme cache from the Presentation page.
    Have you updated recently and what was the old version you had ?

    Also, how many and which shipping modules are installed?

    @mihai, took a look at the code and this condition can only happen if there isn’t a shipping method selected when the calculate button is clicked. But the quotes aren’t displaying on the checkout form.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘[Resolved] New Update 3.8.14.1 does not solve the mess from 3.8.14’ is closed to new replies.
Skip to toolbar