WordPress.org

Support

Support » Multisite » New to MS installing on new server

New to MS installing on new server

  • politjunkie

    @politjunkie

    Hi, I am moving my half dozen sites to a new server so I want to make sure I set them up as multisite as I have never used it before and figured this is perfect time to do so.

    Setting up the first domain this is what I am getting.

    Because your install is not new, the sites in your WordPress network must use sub-domains. The main site in a sub-directory install will need to use a modified permalink structure, potentially breaking existing links.

    Now these are all separate domains so I do not want subdomains, i need sub-directories. Did I do something wrong int he setup?

Viewing 4 replies - 1 through 4 (of 4 total)
  • dgilmour

    @dgilmour

    No, I don’t think you’ve done anything wrong; I think WordPress has simply detected an existing site in the root. This message is warning you that your main site won’t have the same permalink structure if you go down the sub-directory route.

    That’s unavoidable, and many people might not be able to live with that, so I guess that’s why WordPress has insisted on you using sub-domain.

    politjunkie

    @politjunkie

    Maybe I dont understand this as well as I should, I am very much a rook

    Does either make a difference? LIke if my urls are
    site1.com
    sitetwo.com
    othersite.com

    To keep them all their own unique URL I need to do them in directories right? Or am I not understanding this at all?

    politjunkie

    @politjunkie

    Thanks in advance for help

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    No, you can map domains to subsites on a network.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    You can use MultiSite and make the sites, then map the domains.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘New to MS installing on new server’ is closed to new replies.
Skip to toolbar