Support » Plugin: Postman SMTP Mailer/Email Log » New TLDs are causing an error on certain emails

  • Hi,

    I’ve encountered a bug where the Password Reset email that is sent when a user uses the ‘Forgot Password’ link on the WP Login screen is being rejected with an error on screen that says: User cannot reset their password: Your host may have disabled the mail() function.

    I’ve checked with the host and all is working and other emails are fine. After much diagnosing, I have discovered the following:

    In the error logs, it lists this for Postman SMTP: ERROR PostmanWpMail: Exception code=0 message=Invalid "To" e-mail address [email address]
    where [email address] is the email of the user with the new TLD. In this case, their address end in the new ‘.design’ TLD.

    Other users haven’t reported anything and all has been working for them however, this is the only user that’s had the problem and cannot get past it. I believe this to be because of their TLD. It seems Postman SMTP doesn’t yet support the new TLDs.

    I also see this was mentioned on this forum, but not responded, to 6-months ago, here: https://wordpress.org/support/topic/invalid-email-error-with-some-new-tlds/

    Is there any more information you amy need in order to issue a fix for this?

    Thanks and looking forward to your reply,
    Jack

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘New TLDs are causing an error on certain emails’ is closed to new replies.