Support » Plugin: Maintenance » New TinyMCE field for “description” strips formatting!?

  • Resolved bios4

    (@bios4)


    Hi,

    Maintenance plugin version 3.2 introduced a TinyMCE-editor for the “description” part of the maintenance page.

    Unfortunately it seems that all formatting for the “description” part entered to the editor gets stripped by the “the_content”-filter, which results in just the text remaining without line breaks etc.

    I really liked that in previous versions the description could be formatted “freely”, incl. custom line breaks etc.

    How can this behaviour be got back?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello.

    Thank you for using our product.

    It is only your choice what version of plugin you may use.

    You can upload previous version from GitHub.

    https://github.com/Fruitfulcode/Maintenance/releases

    But our developers currently working on this issue, so you may wait some time the next release.

    Regards

    Thanks for the reply.

    So this means that in a future version it will be again possible to enter formatted text in the editor field?

    I don’t want to use outdated plugins, so this would be a very nice addition…

    May I suggest to process the content of the $mt_options['description'] variable in two steps!?

    1. apply the (already available) wp_kses_post()-function
    2. route it through the wpautop()-function with the $br-argument set to true

    By doing this, all paragraphs AND line breaks are available in the end.

    Thanks

    Hello.

    The latest developers version is available on GitHub. Try to use it.

    https://github.com/Fruitfulcode/Maintenance.

    You should replace your data directory to data from the archive.
    If you didn’t change anything in the source files then your configuration will be not lost.

    Regards

    I already had the dev. version in use – it DOES NOT solve the issue.

    The reason is mentioned in my last post: you’re using wp_kses_post() together with the wpautop-parameter. BUT in this case it does not get called with the line-break-parameter.

    Therefore I suggested to do it in a two-step-way (in \load\functions.php):

    • $description_content = wp_kses_post(stripslashes($mt_options['description']));
    • $description_content = wpautop($description_content, true);

    Note the second parameter (forcing to keep line breaks) set to TRUE in the wpautop()-call ^^

    By doing it like this, all formatting is kept as expected.

    Hello.

    If you still will have a problem, please, submit request to our Technical support, you can provide the FTP access and our developers will fix this problem for your project:

    http://support.fruitfulcode.com/hc/en-us/requests/new

    Please, check, are you sure, that using the last version on GitHub and try to replace content one more time. Issue with apply_filter was solved.

    We can’t reproduce your situation on our demo. Everything work correctly for us after the last updates.

    Regards

    Yes, I’m sure I used the most recent version from GitHub – but it’s not working for me as I expect.

    Thanks anyway for offering your help, but as far as my site is not publicly available plus I managed to get the issue resolved by applying the code as shown my last post, there’s no need for your developers to check my install…

    Thanks

    Hello @bios4.

    Issue with line breaks was solved yesterday.

    Updates available on GitHub.

    https://github.com/Fruitfulcode/Maintenance.

    New release planned during 1 week.

    Thank you for your comments and possible inconvenience.

    Regards.

    Great to hear – I’m looking forward to testing the new version.
    I will mark this issue as resolved as soon as it turns out that everything works as expected…

    Merry Christmas to all!

    Thanks,
    Mike

    • This reply was modified 2 years, 11 months ago by bios4.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘New TinyMCE field for “description” strips formatting!?’ is closed to new replies.