• Resolved tpuuska

    (@tpuuska)


    Hello! I have this really weird problem with Yoast SEO and Divi. When Yoast SEO is active, when I’m editing page (I’m running the latest WP + Divi) on the backend editor and I click “View page” from the admin bar, the link opens up a new tab with the same URL and this string: /?preview_id=5110&preview_nonce=1080d20cba&_thumbnail_id=5941&preview=true

    This “preview” page has no content at all (only header & footer areas are shown). Besides this link, it also opens the correct page (without this preview-string). Something also changes inside the page and the fonts etc. are different. I can go back by entering the page edit (back end) mode and by saving the page without doing any changes -> this corrects the font errors on the page.

    These problems go away when I disable Yoast SEO. Also if I change my Theme other than Divi, no problem at all.

    I checked the source code and the button “View page” has the correct URL but for some reason it opens up the preview-string-link to a new tab. What might be causing it?

    WordPress 5.9.3
    Divi 4.17.1 and 4.17.3 tested: problem with both versions
    Yoast SEO 18.7 and 18.5 tested: problem with both versions

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter tpuuska

    (@tpuuska)

    Tested this on two different sites so it affects total of three sites of mine, not a single site issue.

    Plugin Support Michael Tiña

    (@mikes41720)

    Hi @tpuuska

    We understand you’ve identified a possible conflict with Yoast SEO and Divi.

    Could you check if you’re able to replicate this by performing a conflict check and ensuring you only have the Divi Theme and the Yoast SEO 18.7 as the only plugin enabled?

    Thread Starter tpuuska

    (@tpuuska)

    Hello! I did a conflict check as you instructed. Problem is present when troubleshooting mode is ON and theme is set for Divi and Yoast SEO is active (every other plugin is disabled). Tested this on a third Divi+Yoast SEO site I have so in total the problem is present at 3 sites.

    Hi,
    I support @tpuuska, same problem here. When trying to edit something on a page with Divi builder, new tab keeps opening with an empty preview page. Also, cannot save changes. After disabling Yoast Divi starts to work properly. Yoast 18.7, Divi 4.17.3.

    Kind regards, Dariusz

    Thread Starter tpuuska

    (@tpuuska)

    New information: it affects somehow on the settings when I switch “Classic Editor” off from Divi settings. When using block editor (Gutenberg) the links seem to work properly. I also tried a plugin called “Classic Editor” (the most downloaded one from WP.org) and the problem is affects both Divi’s setting of Classic Editor and the plugin of Classic Editor.

    Plugin Support Michael Tiña

    (@mikes41720)

    Hi @tpuuska

    Does this issue occur with a draft or an already published page?

    I tried this on my test site with just Yoast SEO 18.8 as the only plugin enabled (no classic editor or any other plugins) and Divi Theme 4.17.4. I created a new test post with the Divi Builder and published it. Then when clicking on the ‘view’ link for that post from the posts overview section, it showed the page as expected, and I wasn’t able to reproduce the issue you mentioned regarding it opening a new tab with that string (?preview_id=5110&preview_nonce=1080d20cba&_thumbnail_id=5941&preview=true)

    Thread Starter tpuuska

    (@tpuuska)

    I just tried it on a article (post) and it didn’t cause problem there when the Divi is enabled for the article. Only on pages that are published and are built with Divi Builder enabled. I have a test site that has Divi 4.17.4 and Yoast 18.9 where I just tried it.

    There are some cases where the first time clicking “View page” link on Admin bar doesn’t cause it, but when I click back on my browser and go back to the edit mode (backend edit), and click the same “View page” link the problem happens. Here’s what I do to make it happen:

    – Click on WP left menu “Pages” and “All pages” link. Click on any Divi enabled page on the list (or the link “Edit” under the title name). Now I click “View page” on admin bar. If it works, I click back and click it again, and it opens the new tab and the problem is on, some changes on the page are made.

    Thread Starter tpuuska

    (@tpuuska)

    Forgot to ask: Did you have the “Classic editor” enabled in the Divi settings? It only happens when the Classic Editor is enabled in either Divi options OR via Classic Editor plugin (outcome is the same).

    Plugin Support Michael Tiña

    (@mikes41720)

    Hi @tpuuska

    I tried this again with Divi 4.17.4 and Yoast SEO 18.9, and enabled the ‘classic editor’ option in the Divi settings.

    I then created a test page and published it. Then I went back to the pages overview section and when selecting ‘view’ or ‘edit’ back and forth for that test page, I was still unable to recreate this issue from my end.

    Are you able to recreate this issue from a vanilla WP install or test site? If so, please do create a bug report for our team by following the steps here – https://yoast.com/help/how-to-write-a-good-bug-report/

    We recommend that you also reach out to Divi on this as having both teams aware will help in the resolution of this issue.

    Thread Starter tpuuska

    (@tpuuska)

    Hello! I managed to do more troubleshooting. This only happens on Firefox (100.0 and 100.0.1 versions tested). Here is a video where I’m using Firefox 100.0.1 and where I show the problem with Yoast SEO on and off: https://www.youtube.com/watch?v=mGPM8-utcG0

    I did try Chrome and the problem didn’t occur on Chrome browser. I also informed Elegant Themes for Divi troubleshooting as well!

    • This reply was modified 2 years, 2 months ago by tpuuska.
    Plugin Support Michael Tiña

    (@mikes41720)

    Hi @tpuuska

    Thanks for sharing that video. We understand that this issue only happens with the Firefox browser.

    I tested the issue again with this setup:

    -Firefox browser (100.0.2) 64-bit
    -WordPress 6.0
    -Divi 4.17.4 theme
    -Yoast SEO 18.9 plugin
    -Enabled the ‘classic editor’ option in the Divi options
    -Created and published a test page

    From the pages overview section, I tried to click on the ‘view’ option on that published test page more than 10 times but I was still unable to reproduce the issue where it would open the preview in a new tab and load a blank page. It still loaded the page preview as expected (in the same tab).

    We’re glad to hear that you were able to contact Elegant Themes regarding this. Did they have any information to report?

    Thread Starter tpuuska

    (@tpuuska)

    Elegant Themes support is also looking into this but has trouble replicating the issue. I installed Firefox to my Windows 10 laptop and was able to replicate the issue. The key is to add the site as an exception to the Firefox’s popup blocker. I added my site to the exception list and then, when Divi + Yoast SEO are active, and Divi has Classic Editor enabled, the “View page” link causes problem.

    https://youtu.be/QMtIO6sOoo0

    Sometimes when the new tab is opening, but I close the tab before it opens up the page, it affects the CSS on the page as shown in this video to happen two times. It removed images and changed fonts. Also the CSS problem is not consisted inside the page edited, but the Global Footers (from Divi Theme Builder, where you can edit Header and Footer areas globally) change too and they cause sitewide breaks.

    If I disable Yoast SEO, the problem doesn’t occur. Also if I don’t add the site URL as an exception to the Firefox popup blocker, the problem doesn’t occur. What a weird issue! I have two customers that have reported issues caused to their sites and I’m trying to ask if they have the site added to the popup blocker exception list.

    If I wait the pages to load up nicely and not close the new opening tab before it finishes, somehow also increases the possibility for this problem to occur. I’m not sure in what order things should be done but on the video, it happens twice.

    • This reply was modified 2 years, 1 month ago by tpuuska.
    Plugin Support Michael Tiña

    (@mikes41720)

    Hi @tpuuska

    Thank you for all of this information. It looks like it’s a bit difficult to try and reproduce this exact issue from our end, so we would recommend opening a bug report for our GitHub repository so that it’s documented. We understand you’re already in touch with Elegant Themes as well, so that should be helpful as having both teams aware of this issue should help bring a faster resolution.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    BIrdie

    (@goldendust20)

    I just migrated a website and imported the content via AIOWPM. I used Better Search and Replace to ensure the URLs redirect correctly, however, I am also getting this redirect to preview while editing error.

    Backend: Opens preview redirect new tab just by clicking a section, row, or module. Cannot save.

    Front end builder:
    An error has occurred while saving your page. Various problems can cause a save to fail, such as a lack of server resources, firewall blockages, plugin conflicts or server misconfiguration.

    1. I am not using Yoast, I use Rankmath.
    2. All plugins are disabled.
    3. I am using the DIVI theme + builder.
    4. My host is Bluehost
    5. I am using All In One WP Migration to migrate the website

    I’ve used AIOWPM to migrate 50+ websites and host just as many websites on Bluehost that do not exhibit this issue.

    Thank you for your time!

    • This reply was modified 1 year, 11 months ago by BIrdie.
    • This reply was modified 1 year, 11 months ago by BIrdie.
    • This reply was modified 1 year, 11 months ago by BIrdie.
    • This reply was modified 1 year, 11 months ago by BIrdie.
Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘New tab opened when editing page and clicking links (Divi)’ is closed to new replies.