Support » Fixing WordPress » New Sites don't appear in network admin

  • Big problem here, hopefully easy fix and greatly appreciate help. Right now I can see all my current sites but new sites are not being seen in the site admin, when I’m in the network admin. When I go into the network admin I can select the theme and go to ‘administration’ and it works. I can login to the site admin and view the sample post. I have noticed that sites are getting entered into the “wp_blogs” table but aren’t appearing.

    There must be one thing not set properly in the database. There is an error I discovered when upgrading some WP 2.9 MU sites. If you know what might be missing, please suggest and we’ll see if it fixes the problem. Otherwise, I will describe what I had to do to fix the above problem by changing the wp_1_ prefix to wp_ (which should help others with this problem.)

    (1) Database changes: My database had a split wp_table. The wp_options was actually wp_1_options along with a few other tables while wp_site was not in the “1” category. I had to change the prefixes to move the wp_1_tables to wp_tables to get it to work. Some tables are below.


    (2) WP Config problems – did not work with “MULTISITE” true and only worked with ALLOW_WP_MULTISITE set at true. Adding with both resulted in a 500 error. Here is what my config includes – have no idea what it should look like officially:

    define(‘DB_COLLATE’, ”);
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define(‘DOMAIN_CURRENT_SITE’, ‘’ );
    define(‘PATH_CURRENT_SITE’, ‘/’ );
    define(‘WP_ALLOW_MULTISITE’, true);
    define(‘MULTISITE’, true);

Viewing 4 replies - 1 through 4 (of 4 total)
  • Update – Weird – I only see one user added to each new site – it actually adds a user by default who is NOT a superadmin. Why? Is there some type of “default user” defined when a superadmin creates a new account?

    So this is the problem – the “multisite user management” plugin is no longer working and the only user created in these new sites are all a separate user who wasn’t even a superadmin. Very weird.

    OK – we are getting somewhere. Here is something wrong I’ve noticed in the admin – it is suggested I copy this into the wp-config.php

    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    Now if I have a network enabled site putting up sites in subdirectories. Not sure why this was suggested to be installed but it’s not doing anything.

    Weird – changing the whole config worked. However, it’s still ONLY adding one user to new sites. Not great… hopefully there will be someone with a fix for this. Very tough if you’ve upgraded from WordPress MultiUser… Here is the error message I get if I don’t have WP_ALLOW_MULTISITE on the old database which only can be omitted with the new.

    One or more database tables are unavailable. The database may need to be repaired.

    Done – the site_id and blog_id were necessary additions and had to replace everything else. If yo have that in there then wp_allow_multisite becomes unnecessary and it works. The crazy “single user addition” seems to have been fixed to some degree by enabling multisite on these new sites that now appear properly.

    Happy ending. 🙂 I hope this helps someone who had to convert their WP MultiUser site. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘New Sites don't appear in network admin’ is closed to new replies.