WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Resolved] New sitemap_index.xml not being generated

[Resolved] New sitemap_index.xml not being generated

  • Hello,

    after update to 4.1 the sitemap_index.xml is not being generated (404 when loading).

    I am using W3 Total Cache and Cloudflare, don’t know where is the problem.

    What I have noticed also is that if I uncheck the “Check this box to enable XML sitemap functionality.” and Save XML settings, when the page refresh it is activated again and with the box checked.

    Before v4.1 worked fine, is there any settings verification I should do to find the problem?

    BTW,
    I was using this code before in .htaccess

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_URI} !(.*)/$
    RewriteRule ^(.*)$ http://www.mysite.com/$1/ [L,R=301]

    and worked fine. Now I have had to remove it because it was adding / at the end of sitemap_index.xml. Even after removing it, the sitemap is not generated yet.

    BR

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Joost de Valk

    @joostdevalk

    You probably have the part in W3 Total Cache Browser Cache active that says to not handle 404’s for static files within WordPress? If so, add this exception:

    sitemap(_index)?\.xml

    Hi BR,

    I am having the same problem as you.

    I am using WP 3.1.3

    Plugin Author Joost de Valk

    @joostdevalk

    So try the same fix 🙂

    Hi,

    now there is a new problem. In the index it generates

    post-sitemap1.xml and post-sitemap2.xml and the same thing happens (btw, post-sitemap.xml works but doesnt appear in the index).

    If I add them to the browser cache exception it works. But how would be the regular expression?

    post-sitemap(.*).xml ?????

    Thanks a lot for your feedback!!!

    Plugin Author Joost de Valk

    @joostdevalk

    ah right 🙂

    let’s cut it into two exceptions:

    sitemap_index\.xml
    sitemap([0-9]+)?\.xml

    i also have the same issue and adding them lines doesn’t make any difference. Checking my site files the sitemap files aren’t being created anywhere.. 🙁

    Fixed for me!
    Thanks

    Well, that fixed it for me, but another issue crops up.

    Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 188360 bytes) in /home/bschollnick/schollnick.net/wordpress/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 325

    Suggestions?

    I know I have alot of posts, but….

    will you be doing a update to the plugin to fix this issue please?

    newbie here , can someone explain in newbie terms how to add Joostdevalks

    sitemap_index\.xml
    sitemap([0-9]+)?\.xml

    which file , do i use the editor etc , just quick run down on where the option is and what to edit would be a massive help.

    i have disabled the indexation on the yoast plugin

    and have reinstalled XML Sitemap Generator for WordPress 4.0beta4 to generate my sitemaps…….was that a bad move ? or a good move for the short term ?

    when i re-submit my sitemap to google , it downloads to google , but it shows red crosses next to everything !!!

    my site is .

    http://www.show-plates.com

    any help welcomed.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] New sitemap_index.xml not being generated’ is closed to new replies.
Skip to toolbar