Support » Plugin: NS Cloner - Site Copier » New site url same as Cloned site

  • Resolved sladestyle


    I’m a little confused on how this all works. I set siteA as the site to be cloned, give my new site a /path ( ) and a title ( New Site ) and then click CLONE.

    All seems to work fine…all the info looks correct except when I click “visit site” the url is the exact same as the cloned site (

    This doesn’t seem right does it? Should there have been a folder created called “newsite”? I don’t see anything. Are there some obvious steps that I am suppose to be doing?

    I appreciate any help.


Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Never Settle


    When you type the path for the new site are you putting / at the end (if so, it should not be there – only the letters of the path). I’m only asking because there was a / at the end of your example.

    Otherwise, it sounds like you are doing everything correctly.

    By “visit site” do you mean the link in the yellow confirmation box? Or do you mean the “visit site” in the WP dashboard admin bar at the top?

    In the confirmation box (where it usually says “Before you begin” at the top)…. after CLONE does it contain the CLONE stats (site ID, links to the logs, etc.)?

    Have you checked the logs for clues if something went wrong?

    If you want you can send those to us at dev [at] and we’ll take a look. And / or a screenshot too of what it looks like right before and after you click CLONE.

    Thanks, and hope this helps!

    Hi Never Settle,
    Thanks for the quick reply. I will have to try and recreate it tomorrow but will post either screenshots or send you the logs. I ended up scrapping the multisite idea and am in the middle of creating several stand-alone WP sites.

    WP MS would be perfect for my client and the clone plugin even better. He owns 7 vacation rentals and wants each to have their own website but to share the same theme (different theme skin for each) and layout. I thought I was in heaven when I came across your plugin. I hope we can get it to work because setting up separate WP installs is a pain for me and will be a nightmare for him with maintaining them all.

    Thanks again and will update tomorrow.
    Have a great night.

    Plugin Author Never Settle


    Sure thing, Slade. That does sound like the perfect solution for him. We’ll help you get it going if we can. The little extra effort up front is worth the huge time savings in the end. A few important things to keep in mind:

    The cloner can’t copy the main site (ID=1) because the table structure is different. So if you go with WP MS make sure you create a new site manually and build the first site on ID=2 or higher. Then you can build that out completely and clone it as many times as you want, tweak the theme / skin settings and content on the others and be done.

    Also, the cloner will not keep them sync’ed once they are cloned. So it’s best to completely setup the first one all the way before you split them out.

    Ok…I started over with a test site/network and got the same results. First…where do you find the logs?
    I have several screenshots but am not certain how to upload them here. Do I need to upload them to my server and place links?

    Here was the test in a nutshell:
    Created a new WP install and called it “rootsite” I set this site up with WP multisite.
    Created a subdomain with WP install (/rootsite/level1) and called it “level1”.
    In my network admin I went to Sites >> NS Cloner. The cloner screen gave me the option of cloning “level1”. I then input “/rootsite/level2” in Step 2 (so it reads
    Gave the new site a name of “Level 2” in Step 3. Clicked CLONE AWAY.

    When I go to the network admin My Sites…level 2 now shows up. If I go to Sites >> all sites…all 3 show up correctly and with the correct url path.

    Problem…even though the path shows /rootsite/level2 the newly cloned site always goes to /rootsite/level1. Doesn’t matter if you navigate to the Dashboard or View. If I change anything in Level 2 (Theme skin) it also changes for Level 1.

    Let me know either how to find and send you the logs or upload screenshots.

    Thank you very much!

    Plugin Author Never Settle


    Hey! Any logs / images can either be sent to our dev email mentioned in the first reply (dev [at] or using our support page:

    There is a link to the logs in the successful clone operation notice at the top of the page (you can also find them in the cloner plugins folder under /logs).

    I think the problem is the way you have set up the wordpress installation folder in a subdir of the domain. This is an ok / supported setup from the WordPress standpoint, but typically we’ve always run multisite from the root domain like where new sites are either created at if in subdomain mode or if in subdir mode.

    The cloner is probably running into issues trying to automate the necessary replacements in structure from level1 to level2 with that extra /rootsite/ directory since it sounds like you installed WordPress in it’s own directory and not the actual web root. In theory that should still work, but we never actually looked at that scenario before and the logs might have clues as to what is happening.

    If you are able to install wordpress at the actual root of the site that would be a preferred approach – especially when working with multisite.

    Hi, sorry for the late response. I emailed the logs to you.

    You could be right. This is a test site, I wanted to work out any bugs or issues on my end before implementing on the clients actual site. This won’t be a start from scratch type of thing as he already has his main site up and running.

    It isn’t possible for me to set up the test at the root level but the actual site will be using the root level WP install…if this helps.

    Let me know if you find anything that might help.

    Thank you again!

    Plugin Author Never Settle


    Thanks, Slade. We reviewed the logs and it is very strange. Is there no way to test in another environment that will be like the target environment? This is really important.

    I think there might be issues with the multiple layers of sub directories since in your test environment is installed in a subdirectory with subdir sites after that.

    BUT, one other thing you could try…. instead of filling out the new site name like you were:
    ONLY put level2 in that field so that it will look like

    The reason for this is that it already knows its own root folder (/rootsite/). That field is really intended for the site name only. So, in theory it might work, as we use the WP API to do the site creation and so on in a version proof manner.

    Give that a shot. Don’t try to recreate the full path manually for the input into the Cloner. Just treat that field as the name of what you want the new site to have in it’s URL (but the Cloner and WP will handle the full URL.

    Let us know how that goes!

    I’ve recently came across the same bug as Sladestyle.

    I’ve run into the exact same situation. From what I can tell when you have deployed a WP under a subdirectory, in the case of my its http://localhost/wordpress/ any site I cloned will not be linked correctly in the Admin bar. The only way to access the cloned site it seems to to directly enter in the URL.

    I have tried Never Settle’s work around where you should only put in the site name and not the full path to the deployment, but I still get the same behavior. The new Cloned site shows up in all the admin interfaces, however all the menus seemed to be linked bac k to the originally cloned site. I can access the site via typing the full path of the URL, but due to the menuing in WordPress, this makes it un-usable for any sort of deployment if you need to deploy under a sub-directory.

    Its probably best that you set up some Virtual Hosts in your Apache HTTPD.CONF file. You can find a lot of information online about how to do that. This way you can get around the whole subfolder in your path issue.


    Plugin Author Never Settle


    We’re still working on reproducing and getting a fix for this if we can figure out an automated work-around for this scenario, but no ETA. It could be a while as we are super swamped right now.

    However, there is a quick workaround that has worked at least for some. Go into the Site Settings through the Network > Sites and check / update the Site URL (with the box checked to update Home URL as well.

    One response to this approach replied that: “I had to add the WordPress subdirectory to the path. And check the update home box.” And this worked for them. Hopefully it works for others too.

    Plugin Author Never Settle


    We know this topic / issue has had a long history and thank you for your patience. We’ve been working on a solution to support subdirectory installs of Multisite and we are very close to completing this. If all goes well with final testing we could have an update out the door in a week or two that should fix this. We rolled this topic back to unresolved so that we will remember to update the thread when the new version fixing this issue is available. Thanks!

    Team NS

    Hi NS, i was about to install your plugin before I read this thread and your warnings. Glad you mentioned it. I’ll wait and look for your next update, as i too have my MU installed in a subdir. i’m also hoping to see it show as tested with WP 3.6 soon. Thanks for all your efforts!

    Plugin Author Never Settle


    OK! Very happy to announce that this should be fixed in our latest release! Please update and let us know if the latest version resolves this issue in your environment. Marking this resolved for now, but feel free to re-open if necessary.

    You can read more about the new version here:

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘New site url same as Cloned site’ is closed to new replies.