Support » Installing WordPress » New server, now can’t log in and permalinks broken

  • I moved from a Surpass Hosting account to A Small Orange account. I created a WP 2.0 account on the new server, loaded the databases over and parked a domain on the site.

    About 8 hours after i moved the nameservers to my new site, the domain — — is now pointed at the new site.

    The problem is that I can’t seem to log into the admin page and the permalinks are broken (clicking a permalink leads to a 404 message in FireFox.)

    My URL is

Viewing 10 replies - 1 through 10 (of 10 total)
  • OK, I fixed the permalink probem thusly:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php

    # END WordPress

    I added this to the .htaccess

    But I still cannot login.


    Did you read carefully #6 ?

    Well, the name servers are pointed to the right host now,

    So, I’m going to do a flush dsn and reboot my modem and restart.

    I’ll let you know.

    I flushed the dsn, rebooted, and turned off the modem for one full minute.

    Still the same issues.

    I assume its a matter of waiting.

    Can you login if you revert back to the “default” permalinks?

    How can I revert to the default permalinks if I can’t login?

    Anyway … I got sick of waiting for a reply and uninstalled my installation. I reinstalled a new WP 2.0. and it worked fine. I updated the permalink structure and it worked fine. I started uploaded the databases. The posts showed up and the permalinks worked ok. Then I tried to access the admin panel. The script insisted on upgrading the latest version of 2.0. No way around it. No option was given to NOT upgrade.

    Guess what? I can’t bring the admin panel up anymore. It times out.

    How the heck do I fix this thing?

    I fixed the problem by uninstalling the 2.0 and manually reinstalling 1.5.2 and uploading my databases.

    I had to move the .htaccsess to the blogpeoria folder and I have to delete a Structured Blogging plugin. But it works.

    The script insisted on upgrading the latest version of 2.0. No way around it. No option was given to NOT upgrade.

    If I remember well, the imported DB was a 1.5.x – right?
    Knowing that the DB structure (=tables) in 1.5.x and 2.0 are different I’d say WP acts quite as expected: telling you to update your db structure.
    As a general rule – you cannot import a DB from an earlier version in a higher version without running the update.php file.

    I am having a similar problem. I have moved to site5. My domain name is pointed to the right dns now and has been for about 24 hours. ( At the moment my old wordpress blog still exists but it will be going down soon. ( I can login on at xexm, but using the same user name and pass at suzannesblog, it says the password is wrong. None of the permalinks are working, so I manually go to I’m just trying to get into the options panel so I can change it from xexm to I’m new here and not technically savvy. I had a friend upload my database for me… please help!

    I guess you should change the site_url and home values in the options table of the DB. Those are the two URIs set in the Options.
    If you have phpMyadmin acces, follow this guide:

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘New server, now can’t log in and permalinks broken’ is closed to new replies.