Support » Fixing WordPress » New Server, Can’t Connect to Database

  • I’m moving our site (plasmapool.org) to a new server (hostmonster). The domain, which has always been hosted on hostmonster, is staying the same. I used simplescripts to install a version of wordpress, then uploaded my themes and plugins, dropped the pre-installed database tables, and restored my site’s database. For whatever reason, though, I get this dreaded error:

    We were able to connect to the database server (which means your username and password is okay) but not able to select the plasmapo_wp01 database.

    * Are you sure it exists?
    * Does the user plasmapo_wp_01 have permission to use the plasmapo_wp01 database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    When I change the wp-config file back to the database that’s currently on the old server, the site starts working again. How do I make wordpress “see” the new database? I feel like I’m missing a step (not editing a file or something). Thanks for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Use phpMyAdmin (if it is installed), to verify internally all the data: names of database and tables and so ones…

    Thanks for your response, cryonics. I checked everything and it looks fine. I even repaired the tables. It just seems like for whatever reason the site still wants to connect to my old database. I can’t point it to my new one.

    Any other ideas? Is there another file besides wp-config that I should be editing?

    plasmapo_wp01
    there has to be something wrong with this db name

    hm, the host is hostmonster, so the username is given in the database name (username_database). simplescripts created this database and named it wp01, hence the plasmapo_wp01 database name. just to check, i renamed the database “plasmapool” and still had no luck.

    i’m wondering if it has something to do with the plasmapool.org domain name and the server it’s currently connected to? i tested out restoring the database on another domain (i.e., not plasmapool.org) and had no trouble getting the site to show up on that domain.

    I also noticed that when installing a new wordpress installation on the domain (at the root), the new installation won’t try to replace, or write over, the existing blog. That is, simplescripts will think it installed a new installation of wordpress at plasmapool.org, but it actually never seems to touch it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘New Server, Can’t Connect to Database’ is closed to new replies.